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Exercise 1 

1. Getting Started 
This exercise introduces the GEOPAK Drainage workflow to complete the setup 
required for a new project.  The user will review the project information and set the 
preferences.   

GEOPAK Drainage gives you the best design and analysis based on the input that 
you enter.  Engineering judgment must be used to evaluate the output that the 
program produces.  Refer to the TDOT Roadway Design Division Drainage Manual 
for additional guidance. 

1.1 Project Workflow 
The GEOPAK Drainage workflow mirrors a conventional design process beginning 
with the design of the surface collection system (inlets, drainage areas) followed by 
the design of the conveyance system (subsurface pipes, channels). 

Roadway alignments, vertical profiles, and digital terrain models (DTM) may be used 
throughout GEOPAK Drainage to provide pertinent information to the drainage 
design.  All drainage components feature interactive graphical placement tools for 
easy definition of the drainage system. 

Each of these components (inlets, areas, and pipes) is composed of two basic types 
of information: 

• Spatial information describing its location, shape and connectivity. 
• Hydraulic and Hydrologic information describing its properties, conventions 

and other associated attributes. 

1.2 Drainage Components 
GEOPAK Drainage organizes the components of a drainage system according to 
their spatial characteristics.  Spatial information is stored as Nodes, Links and 
Networks.  This information is stored in a *.gdf file – GEOPAK Drainage File. 

Nodes:    A node (inlets, manholes, etc.) is a point with a user-defined location.  The 
location may be in Cartesian coordinates (x,y) or in curvilinear coordinates (station, 
offset).  

Links:   A Link represents a linear feature depicting a path connecting two nodes, 
traversing upstream to downstream.  The path may be straight line or curvilinear 
(along a graphic element). 

Networks:   A network is a system of interconnected nodes and links that form a 
system through which water can flow to a single outlet node. A drainage project 
accommodates any number of Networks. 
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Other associated components in GEOPAK Drainage include: 

Areas:   A drainage area can be represented by a closed boundary or simply keyed-
in (acres or hectares). All flows from a single drainage area are tributary to a single 
Node. There is a one to one correspondence between a node and an area.  
Therefore areas and nodes share the same name (ID). A drainage area may contain 
multiple subareas representing homogeneous features such as soil types and land 
uses (“C” values), thereby allowing composite "C" value calculations. 

Profiles: A profile represents a linear feature depicting a path connecting two nodes, 
it is different than a link in that a path may span multiple links and traverse upstream, 
downstream, or any combinations. The primary purpose of a profile is to allow 
visualization of a profile view between any two nodes in a drainage network. 

1.3 Directory Information 
Class files are located in the directory c:\Projects\Drainage\*.* 

1.4 GEOPAK User Preferences 
a) Copy the Geopak Drainage project template file, DrainageProject.gdf from standard 

directory: C:\Users\Public\Geopak Standards to class project directory: 
C:\Projects\Drainage\  

 NOTE: For your project, the ‘copy to’ location would be your project folder. 

b) Utilizing MicroStation, open DVSR1proposed.dgn using the tdot interface. 

c) Activate GEOPAK by going to Applications > GEOPAK > Activate 
GEOPAK. The GEOPAK User Preferences control the output format of data 
produced using GEOPAK.  Access the User Preferences by selecting Applications 
> GEOPAK> Road > User Preferences. 

 

1-2   Getting Started GEOPAK Drainage V8i (SELECT Series 2) 



Exercise 1 

d) Set the Units to English, Stationing to 12+34, and Working Directory to 
C:\Projects\Drainage\ and click OK. 

NOTE: For your project, this would be your working directory. 

 
 

1.5 GEOPAK Drainage Menu 
a) Access GEOPAK Drainage from MicroStation’s Applications menu: 

 

All items in Drainage can be accessed through this main GEOPAK DRAINAGE 
Menu Bar: 

 

Or by invoking the GEOPAK Drainage Main Tool Box from Tool Boxes>Main: 
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Or they can be accessed through the Drainage Menu which has been added to the 
main menu bar once you load GEOPAK Drainage. 

 

b) Open GEOPAK Drainage project file DrainageProject.gdf that was copied into the 
project directory: C:\Projects\Drainage\. 
 

 
 
 
 
 
 
 
 
 

 
 
 

 
 
NOTE: Every time that you open GEOPAK Drainage, an untitled project will 
open.  Therefore, you must go to Project>Open and select your project .gdf file 
every time you want to edit or continue working on a project.    
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1.6 Project Preferences  
The Project Preferences control the graphic and computational options of the 
drainage system. The Project Preferences may be changed at any time and the 
system can then be redesigned or analyzed utilizing the new preferences.  

a) Select Project > Preferences. 

NOTE:  Each Drainage Project should begin by copying the file in Step 1 of 1.4 into 
the project folder. This step automatically imports all needed preferences. If this step 
is missed, TDOT Standard Preferences may be loaded after opening the 
Preferences window and going to File > Open and navigating to the following file: 
C:\Users\Public\Geopak Standards\TDOTdrainageprefs.dpf 

Review the Preferences by selecting each option in the column and reviewing the 
various options. 

b) Units: 
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c) Project Components: 

 

The following items are set to the defaults and NO CHANGES need to be 
made: 

Drainage Library File (DLB) – C:\Users\Public\Geopak Standards\TDOTEnglish.dlb 

User Preferences – These settings are already set for you for this exercise.   

Drainage Cell Library - C:\Users\Public\MicroStation Standards\cell\STDS.CEL 

Criteria Directory - C:\Users\Public\Geopak Standards\Criteria 

GEOPAK DDB:  C:\Users\Public\Geopak Standards\tdot.ddb 

For each Library and Directory file location, select the explorer button and go 
to the following file locations: 

GPK Job Number – Pick the GPK file and it will automatically set the correct 
number (this only happens if it goes to the correct User Preferences) 

Superelevation Shapes File – Choose DVSR1SEShapes.dgn from the project 
directory 

Design Surface – Choose final.tin from the project directory.  This final tin is a 
combination of the proposed tin and existing tin.  The final tin includes the proposed 
areas inside the slopes and the existing area outside the slopes.  The tin file has 
been created for your use in class.  Refer to the Geopak Road Course Guide 
Chapter 22 for instruction on how to create a final tin file for your project.   
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d) Rainfall Parameters: 

 

Select the appropriate rainfall source for the city closest to the project site.  

See the TDOT Drainage Manual, Chapter 4, Figure 4A-1 or Appendix I. 

NOTE: The Tennessee Department of Transportation Roadway Design Division 
uses the Rational Method for drainage design. 

e) Land Use Options:  

 

 Set the Land Use Option to Single Land Use Item: Rural Steep for this class. 
The Roadway Design Division does not use the option for Multiple Land Use 
Items. All definitions for land use must come from a specific category. 
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f) Frequency Options: 

 

g) Intensity Options: 
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h) Junction Losses Options: 

 

i) Inlet Options: 
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j) Node Options: 

 

k) Link Options: 

 

NOTE: Do not set the Link Slope Decimal to rounding.  This setting is for control of 
Pipe Design not annotation.  If set it will be impossible to design for minimum depth 
drainage structures.   

l) Profile Options, Plan Symbology, Updates and Save Options should be kept at the 
default settings.  Do not make any changes. 

m) Click OK to save changes and dismiss the dialog. 

1-10   Getting Started GEOPAK Drainage V8i (SELECT Series 2) 



Exercise 1 

1.7 Drainage Library 
The Drainage Library is used to store hydraulic, hydrologic, and construction 
standards, which may be shared by different projects and designers.  Each 
GEOPAK Drainage project accesses items from the Drainage Library for use on the 
specific project. 

a) Select Project > Drainage Library.  The library stored in the Preferences will be 
opened by default. 

 

The Drainage Library currently contains five (5) tabs as shown below: 

 

• Rainfall ..  ..........  .... Rainfall Data Source 
• Land Use ............... Land Uses, their corresponding “C” values and symbology 
• Nodes .................... Inlets, Junctions, Manholes, Outlets, etc. 
• Links ...................... Circular Pipes, Elliptical Pipes, Pipe-Arch pipes, Boxes, etc. 
• Spread Section ..... Inventory of varying Spread Cross Sections 

The Rainfall tab stores the rainfall data information to be used on GEOPAK 
Drainage Projects.  GEOPAK Drainage supports rainfall sources in the form of 
intensity duration frequency (IDF) tables, or as coefficients for intensity-duration-
equation formats.   
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b) Select the Rainfall tab, highlight Lebanon, and select Modify to review the various 
options: 

 

NOTE:  See Appendix I for IDF Zone Location Map. 

 

The table contains the Duration-Frequency Table for the Lebanon area. 
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The Land Use tab is used to store runoff coefficients ("C" values) and corresponding 
graphic symbology for each land use. Land uses can then be delineated 
automatically using the selected symbology. 

c) Select the Land Use tab, highlight the Rural Steep item and select Modify to review 
the various options: 

 

 

Note the various land uses and their associated symbology. Chapter 2 will discuss 
how to make a land use file. 
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The Nodes tab contains standard configurations for Grates, Curbs and Slotted drain 
inlets, as well as Junctions, Outlets and Other nodes. The description, plan view 
representation and dimensional information are stored for each node. 

d) Select the Nodes tab, highlight a Grate inlet and select Modify to review the various 
options: 

 

 

Note the various geometric values required for the nodes. 
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The Links tab contains all culverts to be used on drainage projects. Each link type is 
categorized by three properties: Shape, Material and Type (for some combinations 
of Shape & Material); and contains information regarding specific culvert geometry, 
default roughness coefficient and material combination. 

e) Select the Links tab, select Circular from the Shape dialog box and Concrete from 
the Material dialog box.  Highlight the first Circular Concrete pipe, and select Modify 
to review the various options: 

             

 

Note the various geometric values required for the links.
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The Spread Section tab stores standard spread cross sections for roadway, 
shoulders and gutter that can be used on drainage projects. 

f) Select the Spread Section tab, highlight any section, and select Modify to review 
the various options: 

 

 

Note the spread cross section characteristics for the spread item. 
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2. Land Use DGN Files 
This chapter is provided for REFERENCE ONLY. We have provided the land use file 
for you so that all class participants will have the same areas. 

For your own project, these exercises would have to be done prior to beginning GEOPAK 
drainage. 

This exercise allows the user to create a Land Use file.   

2.1 Land Use DGN Creation 
The shapes created in the land use DGN file are used to specify run-off coefficients 
(C value) for different land use areas. These values are then used to calculate the 
composite run-off coefficient. This composite value is used in conjunction with 
rainfall data in the rational formula to calculate the Q discharge for the drainage 
area. This composite run-off coefficient can be manually calculated and entered as a 
value but by creating these shapes this can be done automatically for any drainage 
area specified on your project. 

a) Create a new DGN file for placement of land use shape elements from DGN seed file 
SEED2D.DGN and open it. Reference your proposed file, which contains proposed 
edges of pavement and slope lines. Also reference your survey topo file.  

• Land use.dgn 

NOTE: For further guidance in creating a new DGN file see Exercise 2 of the 
MicroStation V8 Manual 

b) Access D & C Manager from the MicroStation menu bar drop down location  
Applications>GEOPAK> Road>Design & Computation Manager  
or from task navigation with Geopak’s Civil Workflows, it is the second icon from the 
end on the right. 
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c) In D & C Manager go to the land use category under  
Drafting Standards\Exist. Drainage\Land Use.  
There you will see the three categories of land use items used by T.D.O.T. 
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d) Open the desired category and click on the land use item you wish to define on the 
project. Click on Place Influence in the D & C Manager control strip. 

 

NOTE: You should only use types from one section (i.e. Rural-Flat/Permeable or 
Urban).  
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e) Use any MicroStation shape command to draw shapes around the areas. You may 
wish to copy graphics from the reference files to create complex shapes. This could 
be the proposed edge of pavement lines from the proposed file to shape the 
pavement area or perhaps the edge lines from a parking lot or woods area from the 
survey topo file.  Anytime you wish to change to a different land use type just click on 
it in D & C Manager. If you have shapes already defined simply use the MicroStation 
Change Element Attributes command to change their symbology. 

NOTES:  
Shapes must be continuous and closed. Set fill type to None. 
It is not necessary to place shapes to cover all areas absolutely.  Any areas not 
delineated by a land use shape will use the Base C value entered in the Drainage 
Area Definition dialog. 

f) Once shapes have been set up simply reference the DGN file to your proposed DGN 
file and they will be read when you use Delineate Subareas in the Drainage Area 
Definition dialog. 
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 Exercise 3 

3. DTM Drainage Tools 
GEOPAK supports a wide range of tools that allows you to analyze and evaluate the 
drainage patterns of a GEOPAK Digital Terrain Model or TIN file.  These tools are 
useful for delineating and distinguishing watersheds, flow paths, flow directions, and 
hydrographic features.  

This exercise allows the user to become familiar with the Digital Terrain Model (or 
DTM) Drainage Tools. 

See Exercise 22 in the TDOT GEOPAK Road Course Guide for guidance in creating a 
final merged TIN file. 

3.1 Accessing DTM Drainage Tools 
a) Open the file DVSR1proposed.dgn file.   

Note:  The landuse.dgn file has already been referenced into this file for your use.  
Refer to the previous exercise (Exercise 2) or to the Land Use DGN Creation 
document for instructions on creating the land use file.   

b) Open GEOPAK Drainage and select from the Drainage Menu Bar:  
 Utilities > DTM Drainage Tools 
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3.2 Delineate Watershed 
The Delineate Watershed tool outlines and defines a watershed at any location within 
the TIN surface.  The pour point of the watershed is the most downstream point of a 
desired watershed. Once a data point representing the pour point of the watershed is 
indicated the contributing watershed area is computed and delineated.  Pour points 
must be located near sumps (i.e. low points) in the terrain since a point lying on the 
side of a hill does not actually have a contributing area. 

a) Use the Select File button to select the final merged TIN for the project. Then select the 
DTM Drainage Icon Delineate Watershed.  
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b) Click the Pick Boundary Elements button and select the element representing the tin 
hull (the boundary of the TIN file) as shown in the screenshot below.  Data Point to 
accept. 
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c) Click the DP Pour Point.  Data Point in the dgn file in the approximate location shown 
below: 
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d) Click the DP Create Shape button and data point inside the drainage area delineation 
from the previous step.  This procedure will place a temporary fill in the drainage area.  
Data Point to accept this shape and Update the Microstation View to remove the 
temporary fill.  The Drainage Area Shape has been drawn in the dgn file. 

 NOTE: Scrolling or zooming between Step 3 and Step 4 will cause the temporary 
watershed delineation to disappear. However, the information is still present and 
following Step 4 will still create the Drainage Area Shape. 
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3.3 Drainage Patterns 
The Drainage Patterns tool evaluates the flow paths contained within the TIN.  This tool 
performs a downstream trace from the centroid of each triangle.  

a) Select the DTM Drainage Icon Drainage Patterns. Toggle ON Display Only and click 
the Apply button to exhibit the Drainage Patterns for the tin file. 

 NOTE: Throughout this exercise, Display Only will be chosen, if available, so that the 
graphics will delete when the view is refreshed.  

 

NOTE: Pressing the Escape button (on the keyboard) will terminate the current 
process before completion. 
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3.4 Downstream Trace 
The Downstream Trace tool delineates the flow path downstream from a given point in 
the TIN.  The indicated path follows the steepest descent from the point through the TIN 
terminating at a low point or the edge of the TIN.   

a) Select the DTM Drainage Icon Downstream Trace.  Toggle ON Display Only and click 
the Apply button. 

 

NOTE: Setting the Minimum Low Point Depth to a value above 0.00 will allow the 
downstream trace to pass through small, localized depressions and continue 
downstream. 
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b) Click in the design file within the limits of the tin hull.  A downstream trace will appear 
from the cursor data point location to the nearest low point to which the water will drain. 
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3.5 Flow Arrows 
The Flow Arrows tool indicates the direction of flow within the triangles of the TIN.   

a) Select the DTM Drainage Icon Flow Arrows. Toggle ON Display Only, set the arrow 
size as shown, and click the Apply button. 

 

 The Drainage Flow Arrows are drawn in the design file. 
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3.6 Delineate Low Points 
The Delineate Low Points tool locates all low points within a region of a TIN.  A flow 
arrow is placed and the text "LP" is placed at the triangle vertex. This is an excellent tool 
to use when choosing an initial location for catch basins on sag points as well as 
locations in ponding areas.  

a) Select the DTM Drainage Icon Delineate Low Points. Toggle ON Display Only, set 
the arrow size as shown, and click the Apply button. 

 

 The Low Points are drawn in the design file. 
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3.7 Ridge Lines 
The Ridge Lines tool indicates the ridgelines within a TIN.  A ridge line is defined as a 
triangle edge where the flow on each side of the edge is away from the edge 

a) Select the DTM Drainage Icon Ridge Lines. Toggle ON Display Only, and click the 
Apply button. 

 
 The Ridge Lines are drawn in the design file. 
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3.8 Surface Ponds 
The Surface Ponds tool delineates the area(s) of ponded water within the specified TIN.   

a) Select the DTM Drainage Icon Surface Ponds.  Toggle ON Display Only, and click the 
Apply button. 

 

 The surface ponds are drawn in temporary fill as shown below: 
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3.9 Pond Analysis 
The Pond Analysis tool traces a point downstream to a low point and fills it giving the 
volume, maximum depth, and maximum elevation.  In addition, the pond delineation is 
graphically displayed  

a) Select the DTM Drainage Icon Pond Analysis.  Toggle ON Display Only, and click the 
Apply button. 

 

b) Data Point near the location shown below: 
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c) The Pond is filled and pond characteristics computations performed: 

 

NOTE: Other DTM Tools are available from Applications> GEOPAK> ROAD>DTM 
TOOLS. Surface analysis tools are the second from the end. All of these tools are 
available under task navigation through DTM Tools when Geopak’s Civil Workflows is 
active. 
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4.   Culverts 
This exercise shows the user how to use the culvert module to design a culvert. The 
culvert module acts as a standalone component of GEOPAK Drainage, meaning it does 
not directly interact with Drainage Areas, Nodes, Links or Networks. 

4.1 Delineate the Drainage Area 
a) Use DTM tool Delineate Watershed to create the drainage area shown 

below. If necessary, refer back to exercise 3.2 to create the drainage area. 

 The following shape will be used below as the drainage area for this exercise. 

NOTE: The area shown below on level SURVEY - DRAINAGE - Area Shapes extends 
to the limits of the current TIN file. Inspection of the contours will reveal that the 
drainage area most likely extends beyond these limits. Appendix B will discuss options 
to approximate the full extent of the drainage area. 
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b) From the GEOPAK Drainage menu bar select Component>Area>Add.  

Type in 23+20 for the Area ID.  Click OK. 

 

c) Click the Select Shape button. Select and data point to accept the shape 
shown in the first step. The area is automatically calculated. 
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d) Set the Base C Value to 0.350 and click on Compute TC 

 
When the following Dialog will appears, use the explorer button to select the correct TIN 
file. 
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e) Expand window to show details and set Max Sheet Flow Distance to 300’ and 
Max Shallow Flow Distance to 100’. 

 
Collapse the window, toggle ON Sheet Flow, Shallow Flow and Concentrated Flow and 
fill in the values as follows: 

n Value: 0.400 

Inter. K: 0.457 

Velocity: 5.000 

n Values for different surface types are available in the TDOT Drainage Manual, Table 
4-3 Manning’s n Values for Overland Flow 

Intercept K values are below: 

Land Cover / Flow Regime k 
Grassed waterway (shallow concentrated flow) 0.457 

Unpaved (shallow concentrated flow) 0.491 

Paved area (shallow concentrated flow); small upland gullies 0.619 
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Exercise 4 

NOTE:  See Appendix D for additional Manning's N and Intercept K Values. 

f) Click Trace and data point at the furthest hydraulic point. Once values are calculated, 
click Compute. Then click Apply. 
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The Drainage Area Definition is now filled out. 

 

NOTES:  
Minimum Time of Concentration is 5 minutes. If computed time is less than 5 minutes 
input 5 manually. 

For urban areas adjust maximum sheet flow as required. 

For areas that drain directly from sheet flow to concentrated flow, uncheck the Shallow 
Flow box. Leaving this box checked and setting it to zero will not allow TC to be calculated 
correctly. 

After the drainage area has been set up, runoff coefficients can be automatically computed 
with the use of Land Use Items from the Drainage Library. Click on Subareas in the 
Details list on the left.  
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g) Toggle ON Display Only and then click the Automatic Delineation button.  The file is 
scanned for closed shapes matching the Land Use symbology specified in the Drainage 
Library (Land Use Tab).  

 

 

 

h) Click the Apply button to apply the land uses (and their “C” values) to the Drainage 
Area. 
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i) We want to compute the discharge for a 50-year storm so if that is not already set; select 
Project>Preferences>Frequency Options and change the Frequency to the 50-year 
storm. Click the OK button to accept the new preference setting. 

 

j) Return to the Drainage Area Computations>Computation dialog box and click the 
Compute Discharge button: 

 

Verify the Computations; then click Apply to add the Area to the Project. 
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k) Jot down the Computed Discharge from the 50-year storm computed in the step above 
here: ____________ 

l) Recompute the drainage area discharge for the 100 Year storm.  Select 
Project>Preferences>Frequency Options and change the Frequency to the 100 year 
storm. Click the OK button to accept the new preference setting. 

 

m) Return to the Drainage Area Definition dialog box and click the Compute Discharge 
button: 

 

 

n) Jot down the Computed Discharge from the 100-year storm computed in the step above 
here: ____________ 

o) Close the Drainage Area Definition dialog box.  

p) Change the Frequency back to the 50 Year storm 
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4.2 Design the Culvert 
a) From the Drainage main menu, select Component > Culvert> Add. 

 

 

b) Click on the Add button to add a new culvert.  Enter the Culvert Name as 23+20 (station 
of the culvert) and Click OK. 
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c) The Culvert dialog will open as seen below: 

 

d) Enter the culvert discharges from Steps 11 and 14 in the previous exercise. Key-in the 
discharges in the key-in field and click the Add List Item button for each discharge 

  

e) Highlight the 50-yr storm and click Select Discharge. This will be the Discharge that the 
culvert is designed for. 
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You could also just double click to set the desired Design Discharge that the culvert is 
designed for. 

 
f) Define the tailwater.  Set the Tailwater option to Compute and key-in the slope and N 

Value.  

NOTES:  
This slope is the longitudinal slope of the downstream channel. This slope can be 
determine utilizing the Analysis tool: Height/Slope located in 
Applications>GEOPAK>ROAD>DTM Tools 

N Values for different surface channels are available in the TDOT Drainage Manual, 
Table 5A-1 Values of Roughness (See Appendix E). 

 

Set the Slope % to 0.800 and the N Value to 0.040 and click the Extract Cross 
Section button. 
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g) The Define Culvert Tailwater Cross Section dialog will open. Set to Drape Element 
on Model/TIN and TIN File.   
 
Click on the Select Files button and select final.tin. 

 

h) Click the Place Element button to locate the postion of the tailwater cross section that 
is to be extracted (this is notated as the ‘Extracted Profile’ on the dialog).: 

 

GEOPAK Drainage V8i (SELECT Series 2) Culverts    4-13 



i) The Define Culvert Tailwater Cross Section dialog will now contain the profile along 
the element placed representing the channel cross section at this location. 

 

j) Click the OK button and the main culvert dialog will open again. The values for the 
tailwater section will now be populated. 
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k) Select the Configuration tab to define the type of Culvert. Make settings as listed below. 

 

Shape: Circular  
(Culvert Shape: Circle, Box, Ellipse, Etc.) 

Material: Concrete  
(Culvert Material: Concrete, Steel, Plastic, Etc.) 

Headwater Elevation: 836.50  
(The maximum elevation the water can reach at the upstream end of the culvert).  
By default this option is set to Allowable Headwater which uses a height value, 
click to change to Headwater Elevation. 

Maximum Rise: 5.000  
(The maximum diameter, height of the culvert) 

Minimum Rise: 1.500  
(The minimum diameter, height of the culvert) 

Design Barrels: Toggle ON  
(Allows the program to design multiple barrels, if required) 

Number of Barrels: 1 

Roughness: 0.013   
(Determined by the type of Material, See the TDOT Drainage Manual Section 
6.04.2.4.3, Culvert Roughness Coefficients) 

NOTE: If you know the size of culvert you need beforehand you may set Culvert Size to 
‘Library Item’ and pick from the list of defined items. 
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l) Click Select Entrance and select the appropriate entrance condition. The most 
commonly used for TDOT projects is Headwall beveled 45^. Select this condition and 
click ok. This will automatically set the Entrance Ke value. 

 
m) Select the Headwall Location tab to define the location of the Upstream Headwall and 

Downstream Headwall (nodes).  Make settings as listed below. 
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Type: Plan View 

Reference Chain: CL  
(Roadway Centerline) 

TIN File: final.tin 

Library Item: Culvert Endwall 

Alignment: Tangent to Ref. Chain 

+ Angle.: 0 or 180  
(For headwalls parallel to the roadway on the right side use an angle 
adjustment of 180 and on the left use 0. In this case the upstream is on 
left so that value should be set to 0.) 

NOTE:.Another option is to use Mirror Cell. Set angles to 0 and Toggle 
ON for headwalls on the right of the roadway and Toggle Off for headwalls 
on the left of the roadway. Do NOT use Mirror Cell along with Angle 
Rotations as this adds confusion. 

Invert Elev.: TIN / Model  
(Reads TIN elevations. Use ‘User Supplied’ inverts are known or are 
different than TIN file.) 

n) Locate the Upstream Headwall by clicking the Dynamic Place button and setting the 
upstream headwall at a location similar to that shown below:  
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Watch the Headwall Cross Section dialog box 
appear upon mouse-movement.  Use this viewer 
to place the Headwall at the upstream low point.   

Station and offset values for the headwall location 
should change dynamically in the dialog as you 
move your mouse. If not, reset the chain name 
and try Dynamic Place again. It may be 
necessary to close the tool and reopen.  

NOTES:  
To set the headwall locations for 90 degree cross drains, you can enter the centerline 
crossing station with a given offset and click the Keyin Place button. 

You may wish to utilize the DTM Tools>Low Point Tool as discussed in the DTM Tools 
Section 3 in order to predetermine the low point locations. 

o) Locate the downstream headwall by clicking Dynamic Place under the Downstream 
Headwall group.  
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p) Select the Overtopping tab to define the limits of roadway overtopping. Make settings 
as listed below and click Extract PGL Profile.  

NOTE: This step is only necessary if your culvert is in a sag condition. If you are not in a 
sag condition you may proceed to Step 17. 
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Overtopping Source: PGL 
(This option sets the roadway profile as the controlling surface elevation for 
overtopping. Other options include ‘User Supplied’ or constant elevation and 
‘DTM’) 

Width: 48.00  
(This is the width of your roadway) 

Pavement: Toggle ON  
(This should be checked unless your road is not paved) 

Reference Chain: CL  
(Roadway Centerline) 

Ref. PGL: DESIGNCL  
(Roadway Profile) 

Begin Station: 22+00.00  
(Use the DP button to select a point before the Culvert.) 

End Station: 25+00.00  
(Use the DP button to select a point after the Culvert.) 

X Increment: 5.000  
(This may be automatically adjusted depending on the distance between the 
begin station and end station.) 

q) Once the Nodes have been located, and the elevations appropriately calculated, the 
Culvert can be added to the project. Click the Apply button and the culvert will be drawn 
and labeled according to the symbology in the Preferences. 

r) The information to this point is enough to check the culvert computations. Select the 
Computations tab. Toggle on the option to view the Culvert calculations. Click the 
Compute Culvert button to perform the calculations. 
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NOTE: You may include Tailwater and Overtopping calculations (if you need them) by 
toggling ON the option to view them. 

 

 

To view the Culvert Design Results, simply press the "View" button on the lower right of 
the "Culvert" menu to access the output file or you could open the file "23+20.out" from 
your Project Folder.  View and/or print the Culvert Design Results that the Geopak 
Drainage software has calculated for you.  Alternate design options have been found that 
may be considered.  

 

The report also includes hydraulic computations such as Maximum Head Water Depth and 
Outlet Velocity for Q50 and Q100 which are helpful in analyzing the culvert design. 

 
 

 

 

GEOPAK Drainage V8i (SELECT Series 2) Culverts    4-21 



For the 50 year storm, the Head Water Depth is 835.926 ft.  Using the DTM Height/Slope 
tool, a shape may be drawn at that elevation which represents the water surface for this 
storm event.  This is the white shape in the picture below.    
    

       
 
 
The Microstation Change Element Fill Type tool can be used to illustrate the ponded water 
for visual analysis.  Use the Change Attributes tool to change the color to blue if desired. 
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Be sure that your Fill is toggled On in the View Attributes menu. 
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Similarly, a visualization of the Tail Water pond may be created. 
 

 
 

The Drainage Manual states that outlet velocities on Culverts should be based on the 50 
year storm.  In our file 23+20.out, we see that Geopak Drainage has calculated the Outlet 
Velocity for the 50 year storm at 13.567 fps.  
 

 
 
 
The use of riprap as scour protection at a culvert outlet is discussed in Section 6.04.3.3 of 
the Drainage Manual.  It says that riprap can be used to provide protection at a culvert 
outfall for velocities between 5 fps and 12 fps.  Since our velocity is greater than 12 fps, we 
would either need to lessen the slope of the culvert, thereby reducing the velocity at the 
outlet, or we would need to design a stilling basin or some other type of energy dissipator. 
See the Drainage Manual for guidance. 
 

       
 
 

4-24   Culverts GEOPAK Drainage V8i (SELECT Series 2) 



Exercise 4 

Before the next step, go back to “Configurations”, change Culvert Size to “Library 
Item” - 36 Inch Dia Circular. Then, select the Culvert Size drop down and switch 
it to Design Size and set the Maximum Rise to 3. 

 

  

 

 

4.3 Culvert Profile 
At this point, the designer has the pipe size that will be required and can use regular 
Geopak proposed cross section tools to set up a culvert section to finalize the length & 
inverts for the cross drain. 
The next several steps illustrate the functionality available through Geopak Drainage to set 
up a culvert section in profile format along the cross drain.  
a) On the Headwall Location tab click on Create Profile to set up a culvert section and 

finalize headwall locations. The Create Plan View Culvert Profile dialog will open up. 
Make settings as shown below.  

Set Horiz scale 10 and Vert scale 10. 

Change max and min elevations to be the next even 10' up or down.  

Use default values for Max and Min station.  
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b) Click on the Symbology tab and make the following settings: 

 
Ground Line Symbology (Proposed Roadway):  

LV= DESIGN - TYPICAL - Finished Grade and 
Subgrade  
CO= 6, Style=0, WT=4 

Boundary Symbology:  
LV= DESIGN – SHEET – Light Grid 
CO=2, Style=0, WT=4 
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Vertical Grid Major Interval:  
ON, Value=10 

Vertical Grid Minor Interval:  
OFF 

Vertical Grid Major Symbology: 
LV= DESIGN – SHEET – Light Grid  
CO=0, Style=1, WT=1 

Vertical Major Text: 
LV= DESIGN – SHEET – Corner Text 
CO=6, WT=10, TH=2, TW=2, FT=LEROYMON(3) 
Click the Top Center to set Justification 

Horizontal Grid Major Interval:  
ON, Value=10 

Horizontal Grid Minor interval:  
OFF 

Horizontal Grid major symbology: 
LV= DESIGN – SHEET – Light Grid  
CO=0 Style=1 WT=1 

Horizontal Major Text: 
LV= DESIGN – SHEET – Corner Text 
CO=6, WT=10, TH=2, TW=2, FT=LEROYMON(3) 
Click the Middle Right to set Justification 

 
c) Once symbologies are set click on the Section tab and click on Place Profile in the 

lower right of the dialog. Culvert Section graphics will appear on the cursor, Data Point 
out in the open somewhere to place the graphics. Click OK on Create Plan View 
Culvert Profile dialog  to dismiss and reopen the Culvert Edit dialog.  Click Apply to 
store the culvert information. 

  

d) Now that we have placed our culvert section we can finalize our inlet and outlet 
locations. On the Headwall Location tab change Type from Plan View setting to Profile 
View. When prompted to "Convert Plan View Culvert to Profile Culvert" click OK: 
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e) The Headwall location tab will change to show Profile view controls.  

 

 

f) Under Upstream Headwall controls click Station DP button.  Move cursor over 
culvert section profile near the upstream end of pipe. That end will start dynamically 
tracking with cursor movement. Relocate inlet so that the upstream invert of the pipe 
coincides with roadway side slope.  

 NOTE: This location could  be located previously with Microstation commands or 
calculated and input as values in the Invert Sta. & Invert Elev. Keyin fields. 
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g) Repeat this procedure on the Downstream Headwall by clicking on Station DP and 
locating in culvert section profile.  

 

 
h) Once Headwall locations have been reset click on Apply in the upper right corner of the 

Culvert Edit dialog. Now go back to the Computation tab  and this time before clicking 
on Compute Culvert, toggle ON option for Output to ASCII, keyin name 23+20.txt and 
set file to Create option.  

When Compute Culvert is clicked the output data in dialog is updated and text output 
file is created.   
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i) To place drainage info with culvert section profile : 

Set active text settings by going to TDOT>Cross Sections>XS Text Styles Plus, set 
Scale to 10 and select XS Drainage - Prop.: 

 
Go to Microstation's File>Import>Text and pick the file 23+20.txt in your project 
directory. Data Point in the DGN file for placement near the culvert section profile.  This 
data can now be used when filling out TDOT Standard Drainage Data cells or can be 
edited to show additional data needed with the culvert section. 
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5. Storm Drainage Nodes 
This exercise shows the user how to create surface drainage components for storm 
drainage.  The user will add drainage areas, inlets, and outlets as necessary for proper 
roadway drainage design. Unless designing for the interstate, TDOT typically uses a 10-yr 
storm to design (See Appendix J). 
Typically, each segment of the roadway drainage system will have an outlet to a side ditch, 
natural river or stream, or an adjacent storm drainage system. Possibilities of these outlets 
should be considered when determining catch basin locations.   
Initial locations for catch basins (inlets) should be based on the following criteria:  

1.) At all low points (sag points) in the gutter grade or low points behind curbs, 
shoulders or sidewalks 

2.) At the location down grade from the highpoint of a vertical curve where the spread is 
equal to the allowable spread 

3.) At areas where off-site flow will flow across the top of curbs  
4.) Upstream of median breaks, entrance/exit ramp gores, cross walks, street 

intersections, and bridges 
5.) At side streets upgrade from the intersection 
6.) At least every 400 feet (required for maintenance) 

Once these primary locations are determined, adjustments or additions can be made to 
ensure that a safe travel way is maintained. 

5.1 Design Drainage Node CB – 1 
a) Determine the location of the Proposed Inlet.  The proposed roadway is 4 lanes with 

no shoulders and a 6” non-mountable curb with curb and grate inlets. 

 
We will assume for this project that the curb and gutter begins at 0+00.00. We have 
also determined that our maximum allowable spread is 8.0 feet (See TDOT 
Drainage Manual Chapter 7 Section 7.03.3.7). Using sound engineering judgment 
we will assume our first inlet to be at Station 4+00.00 Offset –26.00.  
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b) From the Drainage Main Menu Bar, select Component > Node > Add OR from the 
Main Toolbar, select Add Drainage Node. 

 

c) Type in CB-1 for the node ID.  Leave the Description blank.  Click OK. Over the next 
several steps, we will progress through the Node Configuration until everything has 
been set successfully.   

 
d) Properties > With the Node Id set to CB-1, set the properties as shown below: 

Node Type: Grate 

Profile: On Grade 

Library Item: CB #12 4X3 

(See Standard Drawing D-CB-12S for details.) 
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NOTE: This project calls for a 6” nonmountable curb and gutter inlet. A type 12 catch 
basin is used since it is the most common for this type of gutter. The 4X3 is chosen 
because it requires the least amount of depth for the type 12’s.  It is common 
practice to choose the smallest catch basin at the beginning of the system. Refer to 
the TDOT GEOPAK Drainage Nodes shown in Appendix A to see other sizes and 
types of nodes. 

e) Location > Describe the inlet’s location in the design file as shown below:

Reference Chain: CL 

Profile: DESIGNCL 

Align: Tangent to Chain 

Angle: 0.00 

Station: 4+00.00 

Offset: -26.00 

 
NOTES:  
Once the location options are set, hit enter on your keyboard or data in one of the 
fields to add the catch basin. The angle of the catch basin is automatically set to 
match the centerline. 

If a line or some other MicroStation element is located at the desired station and 
offset, the Station DP   button can be used. If Station DP is active and the 
location is set, DO NOT move out of the dialog because the station range will 
change. Hit enter on your keyboard or data in one of the fields to add the catch 
basin. 
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Other Align Options: 

Tangent to Chain: Allows independent station and offset while matching a 
specified chain’s angle. 

Tangent to Element: Allows independent station and offset while matching an 
elements angle.  

Tangent on Element: Allows independent station (within limits of the element) 
while matching elements offset and angle. (Mirror Node is often 
required when using this option) 

At Point: Allows independent station, offset and angle. 

f) Spread Criteria > Describe the roadway cross sectional characteristics directly in front 
of the inlet.  These values will be utilized to calculate inlet capacity and resulting by-pass 
flow.  Turn ON the display for the reference file: DVSR1SEshapes.dgn and choose the 
following options: 

Longitudinal Slope Source: Reference PGL  

Spread Source: Shape & Lib. Item - 4Lane 

Max Pond Depth: 0.50 feet 

Max Pond Width: 8.00 feet 

 

Change Spread Source back to User Supplied to remove extra links created by 
the combination of the Shape and Library Item. The 24’ link is defined in the library item 
but is not required since we have superelevation shapes for the pavement area, one 
shape for each 12’ lane. Delete the item with 24 for the width, and change the last 
item width from 11.993 to 12 and slope percent from 2.001 to 2. 

g) Spread Criteria > In the previous step, we set the spread section using a combination of 
the project's superelevation shapes and a standard drainage library spread section to 
illustrate that if a final TIN file has not yet been made, other methods could be used. The 
recommended method is to use a final TIN file which should represent the roadway 
accurately at any given inlet location.  
Change the Spread Source to Reference TIN. 
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h) Elevation > Assign the inlet vertical elevation and vertical pipe alignment options. The 

Reference Surface: Tin File should already be set.  
Reference Surface: TIN File - final.tin 

Elevation Source: Reference TIN 
Node Elevation Option: Same as Source 
Vertical Alignment: Min. Fixed Drop, 0.17 
Minimum Depth: 2.38 feet (See first note at top of next page) 
Maximum Depth: 20.00 feet 

 
NOTES:  
Refer to the TDOT GEOPAK Drainage Nodes listing in Appendix A of this 
manual or online for Minimum Depth, Maximum Depth and Min. Fixed Drop or 
Drop Across Bottom of Structure values for a given catch basin type and pipe 
size.  
In Node Configuration, Minimum Depth refers to the Minimum Depth of Cover. It 
does not refer to the minimum depth of the catch basin. Both numbers are 
provided as shown below in a segment of the table taken from Appendix A. 

Drainage Node Cell Drop Max. Pipe Sizes 

Node Description Name Across Depth 15 18 

Name 
 

 
Bottom 

 
Min. Min. Min. Min. 

  

 
of 

 
Depth Depth Depth Depth 

Type: Grate 
 

 Structure 
  

of Cover 
 

of Cover 

CB#10 32"X26" Lowered 6-30 Curb & Grate Inlet CB32X26S 0.12 5.00 
  

3.74 2.12 

CB#10 4X3 6" NonMount. Curb & Grate Inlet CB4X3S 0.17 20.00 
  

3.88 2.21 

CB#10 4’ DIA 6” NonMount Curb & Grate Inlet CB4DIAS 0.17 20.00   3.88 2.21 

CB#10 4X4 6" NonMount. Curb & Grate Inlet CB4X4S 0.17 28.00 
  

3.88 2.21 

CB#12 32"X32" 6" NonMount. Curb & Grate Inlet CB32X32 0.12 4.58 
  

3.74 2.12 

CB#12 4X3 6" NonMount. Curb & Grate Inlet CB4X3 0.17 20.00 
  

3.88 2.21 
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NOTES:  
In the TDOT GEOPAK Drainage Nodes table in Appendix A “Minimum Depth of 
Cover = Minimum Depth - Pipe Size - Drop Across Bottom of Structure” for catch 
basins with both inlet and outlet pipes. To determine Minimum Depth of Cover for catch 
basins with an outlet only: add Drop Across Bottom of Structure to Minimum Depth 
of Cover. The first catch basin in the system is considered an outlet only because there 
are no other pipes (inlets) coming into it.  
For the initial design, use the value given under the 18 in. pipe size. If larger pipes are 
designed, reset the Minimum Depth of Cover to the value for the pipe designed on 
and re-design the network. Steps for this procedure are given in chapter 9 on 
Drainage Navigator /Querying.   
Catch Basins – Inlet and Outlet: 
Min. Depth of Basin – Pipe Size – Drop Across Bottom of Structure = Minimum Depth 

CB#12 4x3:   3.88’   -   18”/12   -    0.17’   =   2.21’ 
 
Catch Basins – Outlet Only: 
Drop Across Bottom of Structure + Min. Depth of Cover = Minimum Depth 

CB#12 4x3:   0.17’   +   2.21’   =   2.38’ 
 

i) Junction Losses > Set to Use Defined Equations (This defaults to the project 
preference settings that were set in Exercise 1): 
 

 
 

 

 

 

5-6   Storm Drainage Nodes GEOPAK Drainage V8i (SELECT Series 2) 



Exercise 5 
 

j) Discharge Options > Specify the source of the discharge contributing to this inlet.  
Toggle Use Computed Discharge: 

 
k) Computations > Verify the inlet’s hydraulic computations: 

NOTE: The Drainage Area for this node hasn’t been added; therefore, the 
computations for the node can’t be completed until a discharge is known. 

 

l) Add this Node to the project by pressing the Apply button.   
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5.2 Delineate Drainage Area CB – 1 
a) According to the TDOT Drainage Manual Chapter 4 Table 4-1 (see Appendix J) 

Hydrologic Design Criteria, the drainage area for CB-1 should be calculated for a 10 year 
frequency.  Select Project>Preferences and change the Frequency Options to the 10 
Year Storm.  Click the OK button to accept the new preference settings.  

 

b) From the Node Configuration dialog select Edit Area. When asked if you want to create 
a new drainage area click Yes.  

 
 

 

 

 
NOTE: If you have closed the Node Configuration Dialog you may create a new 
Drainage Area by going to the Drainage Main Menu Bar, and selecting Component > 
Area > Add OR from the Main Toolbar and selecting Add Drainage Area. 
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Exercise 5 
                       

 

 

The following Add a New Area dialog box will pop up.  Click OK. 
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c) Follow the steps in Exercise 3.2 to delineate and define the drainage area for Catch 
Basin 1. (You may use the following images as reference points. It is ok if your numbers 
do not match exactly.) Attach reference file DA_CB-1. 

Delineate Drainage Area: 

  

d) Define Drainage Area: 

Use Select Shape to identify the drainage area. Our Base C Value was set 
previously in the culvert exercise.   

 

This Base C Value should be set to the most common land use item within your project 
area then only the remaining areas would need land use shapes developed for them.   
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Exercise 5 
e) Calculate Time of Concentration: 

 

Note that the n value for the sheet flow and the Inter. K value for the shallow flow has  
changed and will remain the same throughout this exercise unless noted. 
Sheet Flow – When water flows at a depth of 0.1 feet (1.2 inches) or less 
Shallow Flow – Sheet flow usually becomes shallow flow and flows at a depth above 
0.1 feet (1.2 inches) 
Concentrated Flow – Water flowing in a ditch, gutter, channel, or other drainage 
structure 
The calculated Time of Concentration is GREATER than the minimum of 5 minutes; 
therefore the Time of Concentration will automatically be filled in after hitting Apply with 
NO further steps required. 
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f) Delineate Subareas utilizing the Land Use DGN: 

 

g) Compute Discharge and Apply: 

 
h) Back in the Node Configuration dialog box click on Properties, then click again on 

Computations. This allows the program to update and run calculations. Review the 
Computations. 

 

Don’t be alarmed if your results are off by a few 100th's. It could just be a tolerance 
issue. 

NOTE: Upon review of the computations the Spread Width from Gutter is within our 
limit of 8.0 feet, therefore the inlet is in good position. 
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Exercise 5 
5.3 Design Inlet CB – 2 

It has been determined that another standard CB#12 4X3 will be used.  
 See Standard Drawing D-CB-12S for details. 
CB- 2 will be at nearly the same location as CB-1 but will be on the right side of the 
road. Many of the parameters will be defaulted to those used to place CB-1. 

a) Select from the Main Menu Bar:  Component > Node > Add; or from the Main Toolbar: 
Add Drainage Node; or click the Add Node button within the Node Configuration 
Dialog. 

 
b) Click OK to add CB-2. CB-2 will automatically take the place of CB-1 in the Node 

Configuration dialog which is already open. 

c) Properties > Verify the Node Properties are defaulted from the previous Node (CB-1) 
such that no user-input is required for this similar curb inlet. 
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d) Location > All Reference information is defaulted from the previous Node (CB-1) such 
that only the station,+ Angle (OR Mirror Node but NOT both) and the Offset needs to 
be changed. Change the 

                      Station: 3+70 

Angle: *180 (or toggle on Mirror Node)  

Offset: 26.00 

*(180 for Right side, 0 for the Left), (Mirror Node ON for the Right, OFF for the Left) 

  

e) Click Apply to include this node in the Drainage Project. 
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Exercise 5 
5.4 Delineate Drainage Area CB – 2 

a) From the Node Configuration dialog select Edit Area. When asked if you want to create 
a new drainage area click Yes. The name CB-2 should automatically appear, click OK.  

b) Follow the steps in Exercise 3.2 to delineate and define the drainage area for Catch 
Basin 2. (You may use the following images as reference points. It is ok if your numbers 
do not match exactly.) Attach reference file DA_CB-2 and turn off DA_CB-1. 

Delineate Drainage Area: 

 

 

c) Define Drainage Area: 
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d) Calculate Time of Concentration:  

 
 

The calculated Time of Concentration is GREATER than the minimum of 5 minutes; 
therefore the Time of Concentration will automatically be filled in after hitting Apply with 
NO further steps required.  

Max. Sheet and Max. Shallow Flow Distance values should be the same. 

 

e) Delineate Subareas utilizing the Land Use DGN: 
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Exercise 5 
f) Compute Discharge and Apply: 

 
g) Back in the Node Configuration dialog box click on Properties, then click again on 

Computations. This allows the program to update and run calculations. Review the 
Computations. 

  

Don’t be alarmed if you results are off by a few 100th's. It could just be a tolerance issue. 

NOTE: Upon review of the computations the Spread Width from Gutter is within our 
limit of 8.0 feet, therefore the inlet is in good position. 
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5.5 Design Inlet CB – 3 
It has been determined that another standard CB#12 4X3 will be used.  
 See Standard Drawing D-CB-12S for details. 
 

a) Select from the Main Menu Bar:  Component > Node > Add; or from the Main Toolbar: 
Add Drainage Node; or click the Add Node button within the Node Configuration 
Dialog. 
Click OK to set the name CB-3 

Properties > Verify the Node Properties are defaulted from the previous Node such that 
no user-input is required: 

 

b) Location > All Reference information is defaulted from the previous Node (CB-2) such 
that only the  Angle, Station and the Offset needs to be changed. After a few iterations 
it was determined that CB-3 should be placed at Station 6+20.00: 
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Exercise 5 
c) Elevation > Reset Minimum Depth for a node with both inlet and outlet pipes. 

Minimum Depth: 2.21 FT 

NOTE: SEE Appendix H – Storm sewer sketch, inlet and outlet on the right. 

 

d) Click the Apply button to include this node in the Drainage Project. 

 

 

 

Catch Basins – Inlet and Outlet: 

Min. Depth of Basin – Pipe Size – Drop Across Bottom of Structure = Minimum Depth 

CB#12 4x3:   3.88’    -   18”/12   -   .17’   =   2.21’ 
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5.6 Delineate Drainage Area CB – 3 
a) From the Node Configuration dialog select Edit Area. When asked if you want to create 

a new drainage area click Yes. The name CB-3 should automatically appear, click OK.  
b) Follow the steps in Exercise 3.2 to delineate and define the drainage area for Catch 

Basin 3. (You may use the following images as reference points. It is ok if your numbers 
do not match exactly.) Attach reference file DA_CB-3 and turn off DA_CB-2. 
Delineate Drainage Area: 

 

c) Define Drainage Area: 
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Exercise 5 
d) Calculate Time of Concentration:  

 

 
The calculated Time of Concentration is GREATER than the minimum of 5 minutes; 
therefore the Time of Concentration will automatically be filled in after hitting Apply with 
NO further steps required. 

The maximum length for sheet flow and shallow flow has changed and will vary 
depending upon the drainage area. For this area, set Max. Sheet Flow and Max. 
Shallow Flow to 35. 

e) Delineate Subareas utilizing the Land Use DGN: 
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f) Compute Discharge and Apply: 
 

 
g) Back in the Node Configuration dialog box click on Properties, then click again on 

Computations. This allows the program to update and run calculations. Review the 
Computations. 

  

Don’t be alarmed if your results are off by a few 100th's. It could just be a tolerance 
issue. 

NOTE: Upon review of the computations the Spread Width from Gutter is within our 
limit of 8.0 feet, therefore the inlet is in good position. 
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Exercise 5 
5.7 Design Inlet CB – 4 

It has been determined that another standard CB#12 4X3 will be used.  
 See Standard Drawing D-CB-12S for details. 

a) Select from the Main Menu Bar:  Component > Node > Add; or from the Main Toolbar: 
Add Drainage Node; or click the Add Node button within the Node Configuration 
Dialog. Click OK to set the name CB-4. 
Properties > Verify the Node Properties are defaulted from the previous Node such that 
no user-input is required: 
 

 

b) Location > All Reference information is defaulted from the previous Node (CB-3) such 
that only the + Angle, Station and the Offset needs to be changed. We will set this 
catch basin at the same Station as CB-3.: 

 

c) Click the Apply button to include this node in the Drainage Project. 
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5.8 Delineate Drainage Area CB – 4 
a) From the Node Configuration dialog select Edit Area. When asked if you want to create 

a new drainage area click Yes. The name CB-4 should automatically appear, click OK.  
b) Follow the steps in Exercise 3.2 to delineate and define the drainage area for Catch 

Basin 4. (You may use the following images as reference points. It is ok if your numbers 
do not match exactly.)  Attach reference file DA_CB-4 and turn off DA_CB-3. 
Delineate Drainage Area: 

 
 

NOTE: After a first iteration the spread for the entire contributing drainage area was 
found to exceed the spread limit. After consideration it was determined an area drain 
could collect the water before it spills over the back of the curb. The white shape shows 
the drainage area to be captured by that area drain. (See next Exercise 5.9) 

a) Define Drainage Area: 
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Exercise 5 
b) Calculate Time of Concentration:  

 
The calculated Time of Concentration is less than the minimum of 5 minutes, therefore 
5 must be manually typed in the Drainage Area Definition dialog after hitting 
apply in the Time of Concentration Window. 

The maximum length for sheet flow and shallow flow has changed and will vary 
depending upon the drainage area. For this area, set Max. Sheet Flow and Max. 
Shallow Flow to 10. 

c) Delineate Subareas utilizing the Land Use DGN: 
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d) Compute Discharge and Apply: 

 
 

e) Back in the Node Configuration dialog box click on Properties, then click again on 
Computations. This allows the program to update and run calculations. Review the 
Computations. 

  

Don’t be alarmed if your results are off by a few 100th's. It could just be a tolerance issue. 

NOTE: Upon review of the computations the Spread Width from Gutter is within our 
limit of 8.0 feet, therefore the inlet is in good position. 
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Exercise 5 
5.9 Design Inlet CB – 5 

a) After a first iteration, it has been determined that an area drain needs to be installed 
behind the curb at Station 3+70.00, Offset 35.00’ RT in order to catch flow that would 
otherwise enter the roadway and cause the roadway spread to exceed the allowable 
limit. 
One way to determine the appropriate catch basin to be used is to review TDOT 
Drainage Manual Chapter 7 Table 7-3 Standard Inlet Types and Applications. 
It has been determined that a CB#42 4X4 will be used.  See Standard Drawing D-CB-
42SB for details. 

b) Properties > Change Profile to Sag and change Library Item to CB#42 4X4: 
 

 

c) Location > All Reference information is defaulted from the previous Node such that only 
the +Angle, Station and the Offset needs to be changed: 

 

NOTE: Since CB-5 is an area drain, it does not matter if the angle is 0 or 180, even 
though it is on the right side of the roadway. 
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d) Spread Criteria > For an inlet in a sag, we must specify certain spread criteria for each 
side of an inlet.  

% Slope Left: 1.00 % (From DTM Tools>Analysis>Height/Slope) 
% Slope Right: 1.00 % (From DTM Tools>Analysis>Height/Slope) 
% Discharge Left: 98.00% (Estimated based on placement within drainage area) 
% Discharge Right: 2.00% (Leftover area) 
 

NOTE: Left and Right should be defined based on an inlet at angle = 0.  
In other words:  
Left of inlet is Viewed Left for all inlets at angles <90 and >270. 
Right of inlet is Viewed Right for all inlets at angles <90 and >270. 
Left of inlet is Viewed Right for all inlets at angles >90 and <270. 
Right of inlet is Viewed Left for all inlets at angels >90 and <270. 
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Exercise 5 
 

e) Elevations > Elevation Data must be changed to match a CB#42. From the TDOT 
GEOPAK Drainage Nodes Document set the following: 

Vertical Alignment: Min. Fixed Drop, 0.17 
Minimum Depth: 2.30 feet (See note at top of page 5-7) 
Maximum Depth: 28.00 feet 

 
f) Click the Apply button to include this node in the Drainage Project. 

 

Catch Basins – Outlet Only: 

Drop Across Bottom of Structure + Min. Depth of Cover = Minimum Depth 

CB#42 4x4:   0.17’   +   2.13’   =   2.30’ 
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5.10 Delineate Drainage Area CB – 5 
a) From the Node Configuration dialog select Edit Area. When asked if you want to create 

a new drainage area click Yes. The name CB-5 should automatically appear, click OK.  
b) Follow the steps in Exercise 3.2 to delineate and define the drainage area for Catch 

Basin 5. (You may use the following images as reference points. It is ok if your numbers 
do not match exactly.) Attach reference file DA_CB-5 and turn off DA_CB-4. 

Delineate Drainage Area: 

 

c) Define Drainage Area: 
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Exercise 5 
d) Calculate Time of Concentration:  

 
The calculated Time of Concentration is GREATER than the minimum of 5 minutes; 
therefore the Time of Concentration will automatically be filled in after hitting Apply with 
NO further steps required. 

The maximum length for sheet flow and shallow flow has changed and will vary 
depending upon the drainage area. For this area, set Max. Sheet Flow to 300 
and Max. Shallow Flow to 100. 

e) Delineate Subareas utilizing the Land Use DGN: 
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f) Compute Discharge and Apply: 

 
g) Back in the Node Configuration dialog box click on Properties, then click again on 

Computations. This allows the program to update and run calculations. Review the 
Computations. 

 

Don’t be alarmed if your results are off by a few 100th's. It could just be a tolerance issue. 

NOTE: Upon review of the computations the Spread Width from Gutter is within our 
limit of 8.0 feet, therefore the inlet is in good position. 
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Exercise 5 
5.11 Design Inlet CB – 6 

a) Select from the Main Menu Bar:  Component > Node > Add; or from the Main Toolbar: 
Add Drainage Node; or click the Add Node button within the Node Configuration 
Dialog. Click OK to set the name CB-6 
Properties > Change the Node Properties back to On Grade and to a CB#12 4X3: 
 

 

b) Location > All Reference information is defaulted from the previous Node (CB-5) such 
that only the + Angle, Station and the Offset needs to be changed. Discussion for the 
reason this station was chosen is presented in Step 2 of 5.11.: 

 

NOTE: The Spread Criteria defaults back automatically when the node is changed 
back to ON GRADE, therefore no changes are necessary. 
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c) Elevations > Be sure to change the elevation data back to that which is required for a 
Type 12 catch basin. 

 
d) Click the Apply button to include this node in the Drainage Project. 

 

 

 Catch Basins – Inlet and Outlet: 

Min. Depth of Basin – Pipe Size – Drop Across Bottom of Structure = Minimum Depth 

CB#12 4x3:   3.88’   -   18”/12   -   .17’   =   2.21’ 
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Exercise 5 
5.12 Delineate Drainage Area CB – 6 

a) From the Node Configuration dialog select Edit Area. When asked if you want to create 
a new drainage area click Yes. The name CB-6 should automatically appear, click OK.  

b) Follow the steps in Exercise 3.2 to delineate and define the drainage area for Catch 
Basin 6. (You may use the following images as reference points. It is ok if your numbers 
do not match exactly.) Attach reference file DA_CB-6 and turn off DA_CB-5. 
Delineate Drainage Area: 

 

NOTE: Upon inspection of the entire drainage area, it has been determined that area 
drains need to be installed to collect runoff before it enters the roadway. The white area 
shapes show the area to be collected by these drains which will be input in subsequent 
exercises. 

c) Define Drainage Area: 
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d) Calculate Time of Concentration:  

 
The calculated Time of Concentration is less than the minimum of 5 minutes, 
therefore 5 must be manually typed in the Drainage Area Definition dialog after hitting 
apply in the Time of Concentration Window. 

Since the flow appears to go directly from sheet to concentrated flow we unchecked 
shallow flow. For this area, set Max Sheet Flow to 20. Also note that the n Value 
changes to 0.012 (Asphalt). 

e) Delineate Subareas utilizing the Land Use DGN: 

 
 
5-36   Storm Drainage Nodes GEOPAK Drainage V8i (SELECT Series 2) 



Exercise 5 
f) Compute Discharge and Apply: 

 
 

g) Back in the Node Configuration dialog box click on Properties, then click again on 
Computations. This allows the program to update and run calculations. Review the 
Computations. 

 

Don’t be alarmed if your results are off by a few 100th's. It could just be a tolerance issue. 

NOTE: Upon review of the computations the Spread Width from Gutter is within our 
limit of 8.0 feet, therefore the inlet is in good position. 
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5.13 Design Inlet CB – 7 
It has been determined that a CB#43 8X4 will be used.   
 See Standard Drawing D-CB-43SB for details. 

a) Select from the Main Menu Bar:  Component > Node > Add; or from the Main Toolbar: 
Add Drainage Node; or click the Add Node button within the Node Configuration 
Dialog. Click OK to set the name CB-7 
Properties > Change the Node Properties to Sag and to a CB#43 8X4 (a type #43 
catch basin was chosen due to the fact that this will collect a significant amount of water 
not on the roadway): 

 

 
 

b) Location > All Reference information is defaulted from the previous Node (CB-6) such 
that only the + Angle, Station and the Offset needs to be changed. Pay special 
attention to the placement and rotation of this catch basin. It has been rotated to 
intercept as much runoff as possible: 
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Exercise 5 
NOTE: The following image shows why this location was chosen for CB-7. Upon inspection of 
the TIN File, utilizing the DTM Drainage Tools discussed in Chapter 3, a ponded area was 
discovered at this location. CB-7 was set at the low point of the ponded area. To simplify the 
design and minimize land disturbance, CB-3 and CB-4 were set at the same station. The 
iterative steps required for this determination were not shown in this manual, but would 
be required in an actual design project. 

 
 

c) Spread Criteria > Enter the Spread Criteria as shown below. 
% Slope Left: 5.00 % (From DTM Tools>Analysis>Height/Slope) 
% Slope Right: 3.50 % (From DTM Tools>Analysis>Height/Slope) 
% Discharge Left: 10.00% (Estimated based on placement within drainage area) 
% Discharge Right: 90.00% (Leftover area) 

NOTE: Left and Right are defined by a node at angle 0. To gain your bearing, 
remember this node has been rotated 270 degrees or 90 degrees clockwise. 
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d) Elevations > Elevation Data must be changed to match a CB#43 8x4. From the TDOT 
GEOPAK Drainage Nodes Document set the following: 

Vertical Alignment: Min. Fixed Drop, 0.33 
Minimum Depth: 2.38 feet (See note at top of page 5-7) 
Maximum Depth: 20.00 feet 

 
e) Click the Apply button to include this node in the Drainage Project. 

 

 

Catch Basins – Outlet Only: 

Drop Across Bottom of Structure + Min. Depth of Cover = Minimum Depth 

CB#43 8x4:   .33’   +   2.05’   =   2.38’ 

 

  NOTE: See Appendix A, pg. A-4 
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Exercise 5 
5.14 Delineate Drainage Area CB – 7 

a) From the Node Configuration dialog select Edit Area. When asked if you want to create 
a new drainage area click Yes. The name CB-7 should automatically appear, click OK.  

b) Follow the steps in Exercise 3.2 to delineate and define the drainage area for Catch 
Basin 7. (You may use the following images as reference points. It is ok if your numbers 
do not match exactly.) Attach reference file DA_CB-7 and turn off DA_CB-6. 
Delineate Drainage Area: 

 
 

NOTE: As discussed in Exercise 5.12 Delineate Drainage Area CB-6 this area will catch 
a large amount of runoff prior to it entering the roadway. 

c) Define Drainage Area: 
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d) Calculate Time of Concentration:  

 
The calculated Time of Concentration is GREATER than the minimum of 5 minutes; 
therefore the Time of Concentration will automatically be filled in after hitting Apply with 
NO further steps required. 

NOTE: The maximum length for sheet flow has changed and will vary depending upon 
the drainage area. For this area, the Max Sheet Flow changes to 300 and the 
Max Shallow Flow changes to 100. The n Value for Sheet Flow changes 
back to 0.400 

e) Delineate Subareas utilizing the Land Use DGN: 
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Exercise 5 
f) Compute Discharge and Apply: 

 
g) Back in the Node Configuration dialog box click on Properties, then click again on 

Computations. This allows the program to update and run calculations. Review the 
Computations. 

 

Don’t be alarmed if your results are off by a few 100th's. It could just be a tolerance 
issue. 

NOTE: Review the Computed Data. Items to review specifically are: 

Total Ponded Width, Grate Capacity compared with Computed Discharge and 
Computed Head 
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5.15 Design Inlet CB – 8 
It has been determined that a CB#42 4X4 will be used.  See Standard Drawing D-CB-
42SB for details. 

a) Select from the Main Menu Bar:  Component > Node > Add; or from the Main Toolbar: 
Add Drainage Node; or click the Add Node button within the Node Configuration 
Dialog. Click OK to set the name CB-8 
Properties > Change the Node Properties to Sag and to a CB#42 4X4: 

 

b) Location > All Reference information is defaulted from the previous Node (CB-7) such 
that only the + Angle, Station and the Offset needs to be changed: 
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Exercise 5 
c) Spread Criteria > Enter the Spread Criteria as shown below. 

% Slope Left: 1.00 % (From DTM Tools>Analysis>Height/Slope) 
% Slope Right: 1.00 % (From DTM Tools>Analysis>Height/Slope) 
% Discharge Left: 2.00% (Estimated based on placement within drainage area) 
% Discharge Right: 98.00% (Leftover area) 

NOTE: Left and Right are defined by a node at angle 0. 
 

 
d) Elevations > Elevation Data must be changed to match a CB#42 4X4. From the TDOT 

GEOPAK Drainage Nodes Document set the following: 
 

 
e) Click the Apply button to include this node in the Drainage Project. 

 
 

CB#42 4x4:   0.17’   +   2.13’   =   2.30’ 
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5.16 Delineate Drainage Area CB – 8 
a) From the Node Configuration dialog select Edit Area. When asked if you want to create 

a new drainage area click Yes. The name CB-8 should automatically appear, click OK.  
b) Follow the steps in Exercise 3.2 to delineate and define the drainage area for Catch 

Basin 8. (You may use the following images as reference points. It is ok if your numbers 
do not match exactly.) Attach reference file DA_CB-8 and turn off DA_CB-7. 

Delineate Drainage Area: 

 
NOTE: As discussed in Exercise 5.11 Create Drainage Area CB-6 this area will catch 
runoff prior to it entering the roadway. 

c) Define Drainage Area: 
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Exercise 5 
d) Calculate Time of Concentration:  

 
The calculated Time of Concentration is GREATER than the minimum of 5 minutes; 
therefore the Time of Concentration will automatically be filled in after hitting Apply with 
NO further steps required. 

The maximum length for sheet flow has changed and will vary depending upon the 
drainage area. Keep Max Sheet Flow at 300 and Max Shallow Flow at 100. 

e) Delineate Subareas utilizing the Land Use DGN: 
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f) Compute Discharge and Apply: 

 
g) Back in the Node Configuration dialog box click on Properties, then click again on 

Computations. This allows the program to update and run calculations. Review the 
Computations. 

 

Don’t be alarmed if your results are off by a few 100th's. It could just be a tolerance issue. 

NOTE: Review the Computed Data. Items to review specifically are: 

Total Ponded Width, Grate Capacity compared with Computed Discharge and 
Computed Head 
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Exercise 5 
5.17 Design Inlet CB – 9 

It has been determined that another standard CB#12 4X3 will be used.  
 See Standard Drawing D-CB-12S for details. 

a) Select from the Main Menu Bar: Component > Node > Add; or from the Main Toolbar: 
Add Drainage Node; or click the Add Node button within the Node Configuration 
Dialog. Click OK to set the name CB-9 
Properties > Change the Node Properties to On Grade and to a CB#12 4X3: 
 

 

b) Location > All Reference information is defaulted from the previous Node (CB-8) such 
that only the + Angle, Station and the Offset needs to be changed. The reasoning for 
the location of CB-9 will be given in the drainage area discussion: 

 
 

NOTE: The Spread Criteria defaults back automatically when the node is changed 
back to ON GRADE, therefore no changes are necessary. 
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c) Elevations > Elevation Data must be changed to match a CB#12 4X3. From the TDOT 
GEOPAK Drainage Nodes Document set the following: 
 

 
 

d) Click the Apply button to include this node in the Drainage Project. 
 
 
 
 
 
Catch Basins – Inlet and Outlet:  
 
Min. Depth of Basin – Pipe Size – Drop Across Bottom of Structure = Minimum Depth 
 

CB#12 4x3:   3.88’   -   18”/12   -   0.17’   =   2.21’ 
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Exercise 5 
5.18 Delineate Drainage Area CB – 9 

a) From the Node Configuration dialog select Edit Area. When asked if you want to create 
a new drainage area click Yes. The name CB-9 should automatically appear, click OK.  

b) Follow the steps in Exercise 3.2 to delineate and define the drainage area for Catch 
Basin 9. (You may use the following images as reference points. It is ok if your numbers 
do not match exactly.) Attach reference file DA_CB-9 and turn off DA_CB-8. 

Delineate Drainage Area: 

 
 

NOTE: Many iterations and much investigation went into developing the placement of the 
next few catch basins. The whole of the drainage area if one were to set CB-9 at the same 
station as CB-6 & CB-8 is delineated by CB-9 Area and the white drainage area. These 
were divided to keep the roadway spread within the required limits. The large portion of the 
drainage area and the odd shape will be discussed in Exercise 5.19.  
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c) Define Drainage Area: 

 

d) Calculate Time of Concentration:  

 
The calculated Time of Concentration is GREATER than the minimum of 5 minutes; 
therefore the Time of Concentration will automatically be filled in after hitting Apply with 
NO further steps required. 

NOTE: The maximum length for sheet flow has changed and will vary depending upon 
the drainage area. Keep Max Sheet Flow at 300 and Max Shallow Flow at 
100. 
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e) Delineate Subareas utilizing the Land Use DGN: 

 
f) Compute Discharge and Apply: 

 
g) Back in the Node Configuration dialog box click on Properties, then click again on 

Computations. This allows the program to update and run calculations. Review the 
Computations. 

 

Don’t be alarmed if your results are off by a few 100th's. It could just be a tolerance issue. 

NOTE: Upon review of the computations the Spread Width from Gutter is within our 
limit of 8.0 feet, therefore the inlet is in good position. 
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5.19 Design Inlet CB – 10 
It has been determined that a CB#43 8’ DIA. will be used.  
 See Standard Drawing D-CB-43R for details. 

a) Select from the Main Menu Bar:  Component > Node > Add; or from the Main Toolbar: 
Add Drainage Node; or click the Add Node button within the Node Configuration 
Dialog. Click OK to set the name CB-10 
Properties > Change the Node Properties to Sag and to a CB#43 8’ DIA: 

 
NOTE: 8’ Diameter is a round catch basin. The reasoning behind this selection is the 
need for the grates to be at such an angle that a pipe cannot be attached at a skew 
within the required limits. See TDOT Drainage Manual Chapter 7 Section 7.03.5.5 
Pipe Connections to Structures. 

b) Location > All Reference information is defaulted from the previous Node (CB-9) such 
that only the + Angle, Station and the Offset needs to be changed. The reasoning for 
the location of CB-10 will be given in the drainage area discussion. Especially note the 
Angle and Offset: 
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c) Spread Criteria > Enter the Spread Criteria as shown below. 

% Slope Left: 5.00 % (From DTM Tools>Analysis>Height/Slope) 
% Slope Right: 5.00 % (From DTM Tools>Analysis>Height/Slope) 
% Discharge Left: 50.00% (Estimated based on placement within drainage area) 
% Discharge Right: 50.00% (Leftover area) 
NOTE: Left and Right are set equal since the flow will come to each equally. 

  
d) Elevations > Elevation Data must be changed to match a CB#43 8’ DIA. From 

the TDOT GEOPAK Drainage Nodes Document set the following: 

  
e) Click the Apply button to include this node in the Drainage Project. 

 
Catch Basins – Outlet Only: 
Drop Across Bottom of Structure + Min. Depth of Cover = Minimum Depth 

CB#43 8’DIA:   0.33’   +   2.46’   =   2.79 
 

NOTE: See Appendix A, pg. A-4 

GEOPAK Drainage V8i (SELECT Series 2) Storm Drainage Nodes    5-55 

http://www.tdot.state.tn.us/Chief_Engineer/assistant_engineer_design/design/v8/TDOTGeopakDrainageNodes.pdf


5.20 Delineate Drainage Area CB – 10 
a) From the Node Configuration dialog select Edit Area. When asked if you want to create 

a new drainage area click Yes. The name CB-10 should automatically appear, click OK.  
b) Follow the steps in Exercise 3.2 to delineate and define the drainage area for Catch 

Basin 10. (You may use the following images as reference points. It is ok if your 
numbers do not match exactly.) Attach reference file DA_CB-10 and turn off 
DA_CB-9. 

Delineate Drainage Area: 

 
 

NOTE: Drainage area CB-10 was created by first using downstream trace and discovering 
that it converges into a relatively small area. Therefore when CB-10 was placed, upstream 
trace was used from either side of the catch basin to determine the drainage area. CB-10 
was rotated to match the contours in order to catch as much flow as possible. 
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c) Define Drainage Area: 

 
d) Calculate Time of Concentration:  

 
The calculated Time of Concentration is GREATER than the minimum of 5 minutes; 
therefore the Time of Concentration will automatically be filled in after hitting Apply with 
NO further steps required. 

NOTE: The maximum length for sheet flow has changed and will vary depending upon 
the drainage area. Keep Max Sheet Flow at 300 and Max Shallow Flow at 
100. 
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e) Delineate Subareas utilizing the Land Use DGN: 

 
f) Compute Discharge and Apply: 

 
g) Back in the Node Configuration dialog box click on Properties, then click again on 

Computations. This allows the program to update and run calculations. Review the 
Computations. 

 

Don’t be alarmed if your results are off by a few 100th's. It could just be a tolerance 
issue. 

NOTE: Review the Computed Data. Items to review specifically are: 

Total Ponded Width, Grate Capacity compared with Computed Discharge and 
Computed Head 
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5.21 Design Inlet CB – 11 

It has been determined that another standard CB#12 4X3 will be used.  
 See Standard Drawing D-CB-12S for details. 

a) Select from the Main Menu Bar:  Component > Node > Add; or from the Main Toolbar: 
Add Drainage Node; or click the Add Node button within the Node Configuration 
Dialog. Click OK to set the name CB-11 
Properties > Change the Node Properties to On Grade and to a CB#12 4x3: 

 

b) Location > All Reference information is defaulted from the previous Node (CB-10) such 
that only the + Angle, Station and the Offset needs to be changed: 

 

NOTE: The Spread Criteria defaults back automatically when the node is changed 
back to ON GRADE, therefore no changes are necessary. 
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c) Elevations > Elevation Data must be changed to match a CB#12 4X3. From the TDOT 
GEOPAK Drainage Nodes Document set the following: 

 
d) Click the Apply button to include this node in the Drainage Project. 

 
 
 
Catch Basins – Inlet and Outlet:  

Min. Depth of Basin – Pipe Size – Drop Across Bottom of Structure = Minimum Depth 

CB#12 4x3:   3.88’   -   18”/12   -   0.17’   =   2.21’ 
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Exercise 5 
5.22 Delineate Drainage Area CB – 11 

a) From the Node Configuration dialog select Edit Area. When asked if you want to create 
a new drainage area click Yes. The name CB-11 should automatically appear, click OK.  

b) Follow the steps in Exercise 3.2 to delineate and define the drainage area for Catch 
Basin 11. (You may use the following images as reference points. It is ok if your 
numbers do not match exactly.)  Attach reference file DA_CB-11 and turn off 
DA_CB-10. 

Delineate Drainage Area: 

 

NOTE: There is a small sliver of CB-11 Drainage Area that lies alongside CB-10. This is 
included to make sure all drainage area is captured. In reality, this sliver would likely be 
captured by CB-10 

c) Define Drainage Area: 
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d) Calculate Time of Concentration:  

 
The calculated Time of Concentration is GREATER than the minimum of 5 minutes; 
therefore the Time of Concentration will automatically be filled in after hitting Apply with 
NO further steps required. Keep Max Sheet Flow at 300 and Max Shallow 
Flow at 100. 

e) Delineate Subareas utilizing the Land Use DGN: 
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f) Compute Discharge and Apply: 

 
g) Back in the Node Configuration dialog box click on Properties, then click again on 

Computations. This allows the program to update and run calculations. Review the 
Computations. 

 

Don’t be alarmed if your results are off by a few 100th's. It could just be a tolerance 
issue. 

NOTE: Upon review of the computations the Spread Width from Gutter is within our 
limit of 8.0 feet, therefore the inlet is in good position. 
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5.23 Design Inlet CB – 12 
It has been determined that another standard CB#12 4X3 will be used.  
 See Standard Drawing D-CB-12S for details. 

a) Select from the Main Menu Bar:  Component > Node > Add; or from the Main Toolbar: 
Add Drainage Node; or click the Add Node button within the Node Configuration 
Dialog. Click OK to set the name CB-12 
Properties > Verify the Node Properties are defaulted from the previous Node (CB-11) 
such that no user-input is required for this similar curb inlet. 

 
b) Location > All Reference information is defaulted from the previous Node (CB-11) such 

that only the + Angle, Station and the Offset needs to be changed: 

 

c) Click the Apply button to include this node in the Drainage Project. 
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5.24 Delineate Drainage Area CB – 12 

a) From the Node Configuration dialog select Edit Area. When asked if you want to create 
a new drainage area click Yes. The name CB-12 should automatically appear, click OK.  

b) Follow the steps in Exercise 3.2 to delineate and define the drainage area for Catch 
Basin 12. (You may use the following images as reference points. It is ok if your 
numbers do not match exactly.) Attach reference file DA_CB-12 and turn off 
DA_CB-11. 

Delineate Drainage Area: 

 
 

c) Define Drainage Area: 
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d) Calculate Time of Concentration:  

 
The calculated Time of Concentration is less than the minimum of 5 minutes, 
therefore 5 must be manually typed in the Drainage Area Definition dialog after hitting 
apply in the Time of Concentration Window. 

The maximum length for sheet flow has changed and will vary depending upon the 
drainage area. Max. Sheet Flow is 31 and Shallow Flow should be toggled 
off. The n value should be set to .012. 

e) Delineate Subareas utilizing the Land Use DGN: 
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f) Compute Discharge and Apply: 

 
g) Back in the Node Configuration dialog box click on Properties, then click again on 

Computations. This allows the program to update and run calculations. Review the 
Computations. 

 

Don’t be alarmed if your results are off by a few 100th's. It could just be a tolerance 
issue. 

NOTE: Upon review of the computations the Spread Width from Gutter is within our 
limit of 8.0 feet, therefore the inlet is in good position. 
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5.25 Design Inlet CB – 13 
It has been determined that another standard CB#12 4X3 will be used.  
 See Standard Drawing D-CB-12S for details. 

a) Select from the Main Menu Bar:  Component > Node > Add; or from the Main Toolbar: 
Add Drainage Node; or click the Add Node button within the Node Configuration 
Dialog. Click OK to set the name CB-13 
Properties > Verify the Node Properties are defaulted from the previous Node (CB-12) 
such that no user-input is required for this similar curb inlet. 

 
b) Location > All Reference information is defaulted from the previous Node (CB-12) such 

that only the + Angle, Station and the Offset needs to be changed. This station is not 
set equal to CB-12 due to changing super elevation shapes. After a few iterations this 
station was chosen in order to keep the spread within the limits. : 

 

c) Click the Apply button to include this node in the Drainage Project. 
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5.26 Delineate Drainage Area CB – 13 

a) From the Node Configuration dialog select Edit Area. When asked if you want to create 
a new drainage area click Yes. The name CB-13 should automatically appear, click OK.  

b) Follow the steps in Exercise 3.2 to delineate and define the drainage area for Catch 
Basin 13. (You may use the following images as reference points. It is ok if your 
numbers do not match exactly.) Attach reference file DA_CB-13 and turn off 
DA_CB-12. 

Delineate Drainage Area: 

 

c) Define Drainage Area: 
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d) Calculate Time of Concentration:  

 
The calculated Time of Concentration is less than the minimum of 5 minutes, 
therefore 5 must be manually typed in the Drainage Area Definition dialog after hitting 
apply in the Time of Concentration Window. 

NOTE: Since the majority of flow is in the gutter (Concentrated Flow), we toggle off 
Shallow Flow and change Max Sheet Flow to 20. The n Value for Sheet 
flow changes to 0.012. 

e) Delineate Subareas utilizing the Land Use DGN: 
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f) Compute Discharge and Apply: 

 
 

g) Back in the Node Configuration dialog box click on Properties, then click again on 
Computations. This allows the program to update and run calculations. Review the 
Computations. 
 

 

Don’t be alarmed if your results are off by a few 100th's. It could just be a tolerance issue. 

NOTE: Upon review of the computations the Spread Width from Gutter is within our 
limit of 8.0 feet, therefore the inlet is in good position. 
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5.27 Design Inlet CB – 14 
It has been determined that another standard CB#12 4X3 will be used.  
 See Standard Drawing D-CB-12S for details. 

a) Select from the Main Menu Bar:  Component > Node > Add; or from the Main Toolbar: 
Add Drainage Node; or click the Add Node button within the Node Configuration 
Dialog. Click OK to set the name CB-14 
Properties > Verify the Node Properties are defaulted from the previous Node (CB-13) 
such that no user-input is required for this similar curb inlet. 

 
b) Location > All Reference information is defaulted from the previous Node (CB-13) such 

that only the + Angle, Station and the Offset needs to be changed. This station is 
chosen since it is on an even station and near where we want our outlet: 

 
c) Click the Apply button to include this node in the Drainage Project. 
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5.28 Delineate Drainage Area CB – 14 

a) From the Node Configuration dialog select Edit Area. When asked if you want to create 
a new drainage area click Yes. The name CB-14 should automatically appear, click OK.  

b) Follow the steps in Exercise 3.2 to delineate and define the drainage area for Catch 
Basin 14. (You may use the following images as reference points. It is ok if your 
numbers do not match exactly.) Attach reference file DA_CB-14 and turn off 
DA_CB-13. 

Delineate Drainage Area: 

 

c) Define Drainage Area: 
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d) Calculate Time of Concentration:  

 
The calculated Time of Concentration is less than the minimum of 5 minutes, 
therefore 5 must be manually typed in the Drainage Area Definition dialog after hitting 
apply in the Time of Concentration Window 

NOTE: The maximum length for sheet flow has changed and will vary depending upon 
the drainage area. Change Max. Sheet Flow to 120 and leave Shallow Flow 
toggled off. 

e) Delineate Subareas utilizing the Land Use DGN: 
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f) Compute Discharge and Apply: 

 
 

g) Back in the Node Configuration dialog box click on Properties, then click again on 
Computations. This allows the program to update and run calculations. Review the 
Computations. 
 

 
 

Don’t be alarmed if your results are off by a few 100th's. It could just be a tolerance 
issue. 
NOTE: Upon review of the computations the Spread Width from Gutter is within our 
limit of 8.0 feet, therefore the inlet is in good position. 

This is the last catch basin in this network. The curb and gutter section continues and 
any ByPass will be caught by the next network. If this were not the case, we would need 
to take steps to capture or mitigate the ByPass Flow. 
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5.29 Design Junction MH-1 
a) Select from the Main Menu Bar:  Component > Node > Add; or from the Main Toolbar: 

Add Drainage Node; or click the Add Node button within the Node Configuration 
Dialog. Click OK to set the name MH-1 

Properties > Make the following changes: 
Node Type: Junction 
Library Item: MH#3 5’ DIA 
(See Standard Drawing D-MH-3 for details.) 

 
NOTE:  A manhole is used at this location since; a junction is required, the 
superelevation of the roadway is such that there is little to no flow, and Junction Boxes 
are not allowed to be used under roadways. 

b) Location > All Reference information is defaulted from the previous Node (CB-14) such 
that only the + Angle, Station and the Offset needs to be changed. Be sure manholes 
are located out of wheel paths: 
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c) Elevations > Elevation Data must be changed to match a MH#3 5’ DIA. From the TDOT 

GEOPAK Drainage Nodes Document set the following: 

 
d) Click the Apply button to include this node in the Drainage Project. 

Manhole: 
Min. Depth of Basin – Pipe Size – Drop Across Bottom of Structure = Minimum Depth 

MH#3 5’DIA:   3.54’   -   18”/12   -   0.21’   =   1.83’ 
NOTE: See Appendix A, pg. A-5 

5.30 Design Outlet EW-1 
a) Select from the Main Menu Bar:  Component > Node > Add; or from the Main Toolbar: 

Add Drainage Node; or click the Add Node button within the Node Configuration 
Dialog. Click OK to set the name EW-1 

Properties > Make the following changes: 
Node Type: Outlet 
Library Item: Endwall 
Fix Tailwater at: Critical Depth 

Other Tailwater options are: Uniform Depth, Soffit (Top of pipe), 
or Elevation: User input (known elevation) 
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b) Location > All Reference information is defaulted from the previous Node (CB-14) such 
that only the + Angle, Station and the Offset needs to be changed. Angle is critical as 
to direction node will be displayed.  

 

c) Elevations > Change the Elevation data to the following: 
Vertical Alignment: Match Invert 
Minimum Depth: 0.000 
Maximum Depth: 4.000 

 

 
NOTE: This is a preliminary location used to determine outlet elevation, etc. This node 
will need to be adjusted to account for the side slope, endwall, velocity, and the final 
pipe size which is designed.  
 

5-78   Storm Drainage Nodes GEOPAK Drainage V8i (SELECT Series 2) 



Exercise 5 

 
 

d) Click the Apply button to include this node in the Drainage Project. 

5.31 Inlet Bypass 
Set the Inlet bypass as required to bypass flow to the downstream inlets. 

a) Select Component > Node > Edit or choose from the Tool Box and use the drop-down 
menu to select CB-1. 
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b) Properties > Keyin the By Pass to Node as CB-3 or click the ID button and data point 
on the node in the plan view. 

The Bypass flow from this inlet will then contribute its resulting bypass flow to CB-3.  
Click the Apply button to accept the changes. 

 
c) Select CB-3, Computations > Review the computations to make sure the spread is still 

within the design limits. 

 
d) Follow the same procedures to bypass the remaining flow to the inlets as described in 

the table below: 

Node ID By Pass to Node Spread Width 
    Before Bypass            After Bypass 

CB-2 CB-4 6.0289 

 

7.1331 
CB-3 CB-6 5.5181 5.8409 
CB-4 CB-9 4.0723 6.1784 
CB-6 CB-12 4.8368 5.6188 
CB-9 CB-11 1.7590 3.1144 
CB-11 CB-13 7.2730 7.5241 
CB-12 CB-14 4.8154 5.1393 
CB-13 CB-14 5.1393 5.3333 
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6. Storm Drainage Links 
This exercise shows the user how to utilize the tools necessary for connecting the 
surface drainage (inlets) to the collection system (pipes).  The user will design the storm 
drainage pipes for this project.   

6.1 Link Design 
a) Visually determine the tentative location of the first storm drainage pipe.  This link will 

connect Nodes CB-1 and CB-3. 

 

b) Select from the Drainage Menu Bar: Component > Link > Add or from the main toolbar: 
Add Drainage Link: 
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c) In the New Link window that appears, click OK to set the name SS-1 

 
d) Definition > This dialog sets the pipe configuration including: From Node, To Node, 

Shape, Material, Library Item, etc.  
There are two ways to set the Nodes: from the dropdown list or graphically selecting the 
Nodes. Graphically is recommended to ensure the correct pipe connection points are 
utilized. See note concerning these below. 

To select graphically click the ID button for each and identify the correct Node. SS-
1 traverses From Node CB-1 to Node CB-3:  
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NOTE: All drainage nodes include pipe connection points on the structures (for circular 
structures there are NOT single points but an entire circle for connection). When a 
drainage node is identified for connection it will use the nearest face to the identification 
Data Point. Therefore it is important to Zoom in close enough to drainage nodes 
and identify them at the correct connection point of the structure. Correct and 
Incorrect examples are shown below. 

INCORRECT         CORRECT 

         
The symbolization for drop inlets display the full extent of the sub-structure as opposed 
to the normal smaller symbol used for curb and gutter inlets. This is done so that the 
designer can ensure adequate R.O.W. or easement is provided. For this reason you will 
not see the pipe connection points for these structures since they coincide with the 
structure wall as shown below. 

             
e) Set the remaining Link Configurations as follows: 

Shape: Circular 
Material: Concrete 
Design Size: Toggle ON 
Design Barrels: Toggle OFF 
Number of Barrels: 1 
Roughness: Automatically set based on the selected Material 

NOTES:  
Multiple barrels could be designed, if required, by toggling Design Barrels ON or 
setting Number of Barrels to the determined number. 

If the link size is known, it may be input by toggling Design Size OFF and clicking on 
the Select… button. 
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f) Conditions > The elevations shown are based on the Node Elevation minus the 

min/max depth. These depths were specified in the Node Definition (See Exercise 5) 
Dialog Box for Nodes CB-1 (From Node) and CB-3 (To Node) respectively.  In this case, 
no entries are necessary and GEOPAK Drainage will design all the profiles for this 
project. 

 

 

NOTE: When manually defining Invert elevations for links, make sure the drop across a 
structure is accounted for. In other words, if you were to define the Invert elevations for 
Links SS-1 and SS-3 at CB-3, then make sure the From Node Invert elevation for Link 
SS-3 is at least the minimum drop lower than the To Node Invert elevation for Link SS-1. 
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g) Constraints > Establish the min/max design criteria for Links as follows: 

Rise Min/Max: 1.5 / 4.0 (feet) 

Slope Min/Max: 0.50 / 11.00 (%) 

Velocity Min/Max: 3.00 / 12.00 (fps) 

 

h) Computations > Displays the computed hydraulic properties of the Link.   

 

NOTE: Link hydraulics are not available for review until a Network has been 
established and designed or analyzed successfully (See Exercise 8).  Check back 
here for computations after the Network has been added and designed or analyzed. 

i) Click the Apply button to include this Link in the drainage project. 
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j) Add the remainder of the link conveyance system using Component > Link > Add from 
the Drainage Menu Bar or by clicking the Add Link button as shown below.  

 
As Links are added, most dialog values default from the previous Link with the 
exception of From Node and To Node. Add Links between all of the following Nodes: 

Link SS-2 Traverses From Node CB-2 To Node CB-4 
Link SS-3 Traverses From Node CB-3 To Node CB-6 
Link SS-4 Traverses From Node CB-4 To Node CB-9 
Link SS-5 Traverses From Node CB-5 To Node CB-2 
Link SS-6 Traverses From Node CB-6 To Node CB-12 
Link SS-7 Traverses From Node CB-7 To Node CB-3 
Link SS-8 Traverses From Node CB-8 To Node CB-6 
Link SS-9 Traverses From Node CB-9 To Node CB-11 
Link SS-10 Traverses From Node CB-10 To Node CB-9 
Link SS-11 Traverses From Node CB-11 To Node CB-13 
**Link SS-12 Traverses From Node CB-12 To Node CB-14** 
**Link SS-13 Traverses From Node CB-13 To Node MH-1** 
Link SS-14 Traverses From Node CB-14 To Node MH-1 
Link SS-MH1 Traverses From Node MH-1 To Node EW-1 

   ** See notes on next page ** 
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6.2 Curved Links 
a) Use MicroStation’s Place Arc Tool and use the settings ‘Method: Start, Mid, 

End’ to draw a curved element (must be a continuous line string) between the 
nodes and following the middle of the gutter to the extent possible.  

NOTE: Make sure the ends of the MicroStation Element terminate at the correct 
attachment point on the catch basin. 

b) In the Link Configuration Definition dialog toggle ON Use MS Element. 
 

c) Click the Select Element button then Data Point on the element created in Step 1. Then 
click Apply. 

 

 
NOTE: Be sure to toggle Use MS Element OFF for subsequent Links that are not 
curved. When used, the Link position and length are defined by the MS Element. 
Caution must be used in order to properly define the Link. 

GEOPAK Drainage V8i (SELECT Series 2) Storm Drainage Links    6-7 



6.3 Storm Drainage Network Design 
a) Select the Add Drainage Network tool or select Network > Add from the main drainage 

menu bar. 

 

 

b) In the Add a New Network dialog, enter the following information: 

Network ID: WEST 
Outlet Node: EW-1 

 

NOTE: The Outlet Node may be selected via the dropdown or by clicking ID Outlet and 
selecting the Node in the plan view. 

c) Click OK in the Add a New Network dialog box. 
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d) Click the Build Network button.  This feature verifies the nodes and link connectivity.  

 
Click OK. 

 

e) Click the Highlight Network feature. This Feature highlights all components (areas, 
inlets, pipes, etc.) connected to the active Network. 
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f) Verify that all network components are highlighted. 

 

g) Click the Apply button.  Network “WEST” has been added to the project. 

h) Click the Design button.  This command initiates the hydraulic design of the components 
contained in the Network.  
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 Click OK. 

 
i) Review errors to determine steps needed to correct and close the text editor. (See 

Appendix C for common errors and fixes) 

 

 

NOTES:  
Pressing Design or Analyze should be the last step in Designing or Analyzing the 
Network.  

Design performs hydraulic design of the network and designs components of the 
network as indicated by the ‘design toggles’. Analyze performs hydraulic analysis of the 
network as is and ignores all ‘design toggles’. 
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Lock and Unlock buttons allow the user to lock or unlock all components in a network 
at the given Size or Elevation. Caution must be used when selecting Unlock as this 
action will unlock ALL Sizes or Elevations, including ones that should not have been 
unlocked. 

After Design or Analyze has been utilized, computation values are shown in each link 
configuration of the network which can be reviewed in the Link Configuration edit dialog. 
Other methods of reviewing this data will be discussed in Exercise 10, Drainage 
Navigator.  
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7. Ditch Nodes and Links 
This exercise shows the user how to utilize the tools for nodes and links for ditch 
analysis. We will investigate the drainage flow along a fill slope with these settings and 
in a later chapter define a special ditch to manage it. 

7.1 Ditch Node Design DIT-1 
Begin Ditch 

a) Visually determine the tentative location of the beginning of the ditch.  In this case a 
ditch is created along the south side of the roadway by the new fill slopes. 

 

b) Select from the Drainage Menu Bar: Component > Node > Add or from the main 
toolbar: Add Drainage Node. 

c) In the New Node window that appears, set the name DIT-1 and click OK. 
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d) Properties > Set Node Type to Other and Library Item to Ditch Begin.  

 
e) Location > All settings should have carried over from the last Node input. Review and 

make the following changes: 
Station: 8+50.00 
Offset: 32.50 
+Angle: 0.00 

 

This will approximate the beginning of the ditch as shown below: 
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NOTE: The Spread Criteria configuration is not required for Other node types such as 
are used by ditches. 

f) Elevations > All settings should have carried over from the last Node input. Review and 
make the following changes: 

Vertical Alignment: Match Invert 
Minimum Depth: 0.00 
Maximum Depth: 0.00 

 

g) Discharge Options > Leave Use Computed Discharge selected and click Apply to 
save all settings. 

 
NOTE: For short ditches where only a single drainage area is utilized, the Link Base 
Flow Area option should be toggled ON and set to add the discharge for that area. It is 
then toggled off at the ditch outlet. If this is not toggled OFF at other nodes beyond the 
beginning, the discharge will accumulate at each node and not accurately represent the 
area’s discharge. 
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7.2 Delineate Drainage Area DIT-1 
Begin Ditch Drainage Area 

a) From the Node Configuration dialog select Edit Area. When asked if you want to create 
a new drainage area click Yes. The name DIT-1 should automatically appear, click OK.  

b) Follow the steps in Exercise 4.1 to delineate and define the drainage area for the begin 
ditch location. (You may use the following images as reference points. It is ok if your 
numbers do not match exactly.) Attach reference file DA_DIT-1. You may want 
to turn off the level SURVEY – DRAINAGE – Area Shapes to see the ditch easier. 
Delineate Drainage Area: 

  

NOTE: The drainage area should be broken into sections for long ditches, however, for 
short ditches; determine the area from the most downstream point (i.e. the stream 
outlet). 

c) Define Drainage Area: 
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d) Calculate Time of Concentration:  

 
Make settings as shown for Max Sheet Flow and Max Shallow Flow. We will use 
these settings for all the ditch areas. 

The calculated Time of Concentration is GREATER than the minimum of 5 minutes; 
therefore the Time of Concentration will automatically be filled in after hitting Apply with 
NO further steps required 

e) Delineate Subareas utilizing the Land Use DGN: 
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f) Compute Discharge and Apply: 

  

7.3 Ditch Node Design DIT-2 
a) Visually determine the location of any major ditch change; such as a change in 

horizontal or vertical alignment or a change in cross section.  
In this initial set up we are analyzing the flow along the fill slope and will set them as 
shown. 

  

b) Select from the Drainage Menu Bar: Component > Node > Add or from the main 
toolbar: Add Drainage Node. 

c) In the New Node window that appears, set the name DIT-2 and click OK. 
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d) Properties > Set Node Type to Other and Library Item to Ditch Change.  

 
e) Location > All settings should have carried over from DIT-1. Review and make the 

following changes (estimated change locations): 
Station: 9+25.00 
Offset: 36.00 

 

f) Click Apply. 
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7.4 Delineate Drainage Area DIT-2 
a) From the Node Configuration dialog select Edit Area. When asked if you want to create 

a new drainage area click Yes. The name DIT-2 should automatically appear, click OK.  
b) Follow the steps in Exercise 4.1 to delineate and define the drainage area for this ditch 

change location. Attach reference file DA_DIT-2 and turn off DA_DIT-1. 

 
Delineate Drainage Area: 

  

c) Define Drainage Area: 
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d) Calculate Time of Concentration:  
 

 

 

 

The calculated Time of Concentration is 
GREATER than the minimum of 5 minutes; 
therefore the Time of Concentration will 
automatically be filled in after hitting Apply with 
NO further steps required 

 

 

 

 

 

 

 

 

e) Delineate Subareas utilizing the Land Use DGN: 
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f) Compute Discharge and Apply: 

  

7.5 Ditch Node Design DIT-3 
Repeat previous steps on pages 7-7 & 7-8 creating ditch change Node DIT-3 at 
Station: 10+90.00 and Offset: 34.00. All other information should remain unchanged. 
 

7.6 Delineate Drainage Area DIT-3 
a) From the Node Configuration dialog select Edit Area. When asked if you want to create 

a new drainage area click Yes. The name DIT-3 should automatically appear, click OK.  
b) Follow the steps in Exercise 4.1 to delineate and define the drainage area for this ditch 

change location.  
Delineate Drainage Area: 
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c) Define Drainage Area: 

  
d) Calculate Time of Concentration:   

 

 

 

 

The calculated Time of Concentration is 
GREATER than the minimum of 5 minutes; 
therefore the Time of Concentration will 
automatically be filled in after hitting Apply with 
NO further steps required 
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e) Delineate Subareas utilizing the Land Use DGN:  

  
f) Compute Discharge and Apply: 
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7.7 Ditch Node Design DIT-4 
a) Visually determine the location of the ditch outlet.  

  

b) Select from the Drainage Menu Bar: Component > Node > Add or from the main 
toolbar: Add Drainage Node. 

c) In the New Node window that appears, set the name DIT-4 and click OK. 

d) Properties > Set Node Type to Outlet, Library Item to Ditch Outlet and Fix Tailwater 
at Critical Depth  
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e) Location > All settings should have carried over from DIT-3. Review and make the 
following changes: 

Station: 13+15.00 
Offset: 58.00 

 

f) All other options should be set from previous nodes, click Apply. 

7.8 Delineate Drainage Area DIT-4 
a) From the Node Configuration dialog select Edit Area. When asked if you want to create 

a new drainage area click Yes. The name DIT-4 should automatically appear, click OK.  
b) Follow the steps in Exercise 4.1 to delineate and define the drainage area for this ditch 

outlet location.  
Delineate Drainage Area: 
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c) Define Drainage Area: 

 
d) Calculate Time of Concentration:  

 

 

 

 

The calculated Time of Concentration is 
GREATER than the minimum of 5 minutes; 
therefore the Time of Concentration will 
automatically be filled in after hitting Apply with 
NO further steps required 
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e) Delineate Subareas utilizing the Land Use DGN:  

  
f) Compute Discharge and Apply: 

  
g) Since Node DIT-4 is an outlet type, it will not consider the drainage area developed for 

it. In order to ensure the final ditch link, will be adequate for the capacity at the end we 
will need to link the DIT-4 drainage area to Node DIT-3. 

Go to Component> Node> Edit and select node DIT-3. Under Discharge Options 
click on the option to Link Base Flow Area and set to include the DIT-4 drainage area. 
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7.9 Ditch Link DIT-1  
We are checking the drainage flow along a fill slope so all links are set up as cross 
section based. The surface is read for the ditch shape and capacity is calculated at 
each cross section that is cut along the links. 

Cross Section Based Link DIT-1 
a) Select from the Drainage Menu Bar: Component > Link > Add or from the main toolbar: 

Add Drainage Link 

b) Set the Name to DIT-1 and click OK. 

c) Set the From Node as DIT-1 and the To Node as DIT-2 via the dropdown list or by 
clicking the Node ID button and selecting the appropriate node. 

d) In the Details portion of the dialog change Type to Ditch. 

e) In the Configuration portion of the dialog set the following: 

Ditch Type: Cross Section Based 

Roughness: 0.027 (See TDOT Drainage Manual Chapter 5 Table  
5A-1 for typical values) 

Number of Cross Sections: 5 (Typically one cross section every  
5 feet to a maximum of every 50 feet for long 
ditches) 

Width of Cross Sections: 100 (Ensure top of bank on both sides  
is captured) 

  
f) Click Apply and review the cross section lines displayed in the plan view (shown on next 

page) to determine if adjustments should be made.  
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NOTES:  
Since we are using the Cross Section Based ditch type to analyze existing conditions, 
the Conditions and Constraints require no special settings. In the system modification 
chapter, we will use those to control the proposed ditch that is to be designed. 

Computation will not show any information until a drainage network is built from the 
nodes and links in this ditch system.  

This same set up using the Cross Section Based ditch type can be used to analyze 
long proposed roadway ditches for capacity and function. 
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7.10 Ditch Link DIT-2 
         Cross Section Based Link DIT-2 

a) Select from the Drainage Menu Bar: Component > Link > Add or from the main toolbar: 
Add Drainage Link 

b) Set the Name to DIT-2 and click OK. 

c) Set the From Node as DIT-2 and the To Node as DIT-3 via the dropdown list or by 
clicking the Node ID button and selecting the appropriate node. 

d) In the Details portion of the dialog change Type to Ditch. 

e) In the Configuration portion of the dialog set the following: 

Ditch Type: Cross Section Based 

Roughness: 0.027 (See TDOT Drainage Manual Chapter 5 Table 5A-1 for typical 
values) 

Number of Cross Sections: 10 (Typically one cross section every  
5 feet to a maximum of every 50 feet for long ditches) 

Width of Cross Sections: 100 (Ensure top of bank on both sides is captured) 

  

f) Click Apply.  
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7.11 Ditch Link DIT-3 
Cross Section Based Link DIT-3 

a) Select from the Drainage Menu Bar: Component > Link > Add or from the main toolbar: 
Add Drainage Link 

b) Set the Name to DIT-3 and click OK. 

c) Set the From Node as DIT-3 and the To Node as DIT-4 via the dropdown list or by 
clicking the Node ID button and selecting the appropriate node. 

d) In the Details portion of the dialog change Type to Ditch. 

e) In the Configuration portion of the dialog set the following: 

Ditch Type: Cross Section Based 

Roughness: 0.027 (See TDOT Drainage Manual Chapter 5 Table  
5A-1 for typical values) 

Number of Cross Sections: 10 (Typically one cross section every 5 feet to a 
maximum of every 50 feet for long ditches) 

Width of Cross Sections: 100 (Ensure top of bank on both sides is captured) 

  
 

f) Click Apply.  
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Exercise 8 

8. Ditch Networks 
This exercise shows the user how to setup a network and perform network 
computations. 

The Network computations serve as the final calculation process in the design or 
analysis of a storm drainage system. A GEOPAK drainage network is defined as a 
series of interconnected nodes, links and areas which drain to a single outlet. GEOPAK 
drainage accommodates multiple networks in a single drainage project. 

8.1 Ditch Network Design 
a) Select the Add Drainage Network tool, select Network > Add from the main drainage 

menu bar or click the Add Network button in the Network Configuration Dialog. 

 
b) In the Add a New Network dialog, enter the following information: 

Network ID: WEST DIT 
Outlet Node: DIT-4 

 

NOTE: The Outlet Node may be selected via the dropdown or by clicking ID Outlet and 
selecting the Node in the plan view. 

c) Click OK in the Add a New Network dialog box. 
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d) Click the Build Network button. Click OK. 
e) Click the Highlight Network feature.  
f) Verify that all network components are highlighted. 

 
NOTE: The drainage area DIT-4 will not be highlighted since it is built for an outlet node 
type which does not consider drainage areas. In the previous chapter, we linked that 
area to node DIT-3 so that it is covered in this ditch drainage analysis. 

g) Click the Apply button. Network “WEST DIT” has been added to the project. 
h) Click the Design button, then click OK. 
i) Review errors to determine steps needed to correct and close the text editor. (See 

Appendix C for common errors and fixes) 
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8.2 Ditch Link Review 
Now that the ditch network has been built and designed, we can review the computation 
results for the existing ditch links in the network. 

a) Select the Edit Link tool, select Component> Link> Edit from the main drainage menu 
bar or click the Edit Link button in the Network Configuration Dialog. 
Set to link DIT-1 and select Computation. 

 
b) Scroll down through the computation results to the data following the Width of Cross 

Sections. 
This data represents conditions at each cross section drop along the link. Note that 
these points start at the end of the link and come back up the link to the beginning. 
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The first data group provides the cross section number (0-4 in this case with 5 cross 
sections), distance from end, water surface elevation, energy grade line elevation and 
velocity. 

 
 

c) Scroll down further to review the second data group. 
The second data group provides the cross section number, number of slope break 
points in cross section, critical depth elevation, and top of water surface width. 
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d) Switch to our other ditch links, DIT-2 & DIT-3, and review the computed data. 

 
Using this information, we can determine if the existing conditions are adequate to 
convey the water along the fill line and critical points where more capacity may be 
required. 
If using this methodology to analyze long proposed roadway ditches, you can determine 
locations where special ditches may be required as the depth\volume becomes too 
great for the regular ditch to handle. 

8.3 Select Active Network 
With the possibility of multiple networks in a single drainage project it may be necessary 
to choose an Active Network to utilize certain GEOPAK Drainage Features. 

a) Select the Set Active Network tool, select Network > Active Network from the main 
drainage menu bar or click the Add Network button in the Network Configuration Dialog. 
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b) Select the network West and click OK. 
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9. Profiles 
This exercise shows the user how to perform profile computations and properly display the 
drainage profile.   
Profiles can be constructed in a path running in either direction, upstream or downstream, in a 
drainage network. The Profiles dialog is used to display customized profiles including 
groundline, nodes, links, depth of cover, hydraulic grade line, etc.  

9.1 Storm Drainage Profile Design 
a) Select from the Menu Bar: Component > Profile > Add or from the main toolbar: Add 

Drainage Profile 

 

b) Complete the Profile Configuration dialog box information as follows for the left side of 
the roadway in the WEST drainage network.  Click Apply when finished. 

Profile ID: WestLT From Node: CB-1 To Node: EW-1 

 

NOTE: To select the appropriate node; use the dropdown menu or use the ID node 
button and select the node from the plan view. From Node and To Node must be in 
the same network. 
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c) Load the Profile Preferences file.  Inside the Edit Drainage Profile dialog, click File > 
Open.   

  
Navigate to C:Users\Public\Geopak Standards\ and select 
TDOTStormSewerProfiles-Design.ppf.  Click Open.   

 
All settings have been set for the profile. To view the settings, click on the Display, 
Drainage Information and Grid & Labels tabs. They should look as shown below. 
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NOTE: During the design process these preferences can be modified to display needed 
information. However, when projecting to a profile (see Exercise 9.2) the settings should 
match those defined in profile preference file TDOTStormSewerProfiles-Plan.ppf. 

d) Click the Registration tab and make the settings as below in the Registration Point, 
Scale and Reference Surface portions (ignore the Projection portion for now). The 
Registration Point will correspond to the lower left corner of the profile and can be 
wherever an open space is available. Click Apply. 
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e) Review the profile for anything that needs to be corrected. 

f) Repeat steps a-d to create the following profiles: 

NOTE: All Profiles should go forward with the alignment so they can be projected to the 
roadway alignment profile at a later time. 

See the following pages for images of the profiles. 

  

Profile ID From Node  -  To Node Registration Point 

WestRT CB-2  -  EW-1 X = 7500 

 

Y = 1000 

CB5 CB-5  -  CB-2 X = 9000 Y = 1000 

CB7 

 

CB-7  -  CB-3 X = 9000 

 

Y = 2500 

CB8 CB-8  -  CB-6 X = 9500 Y = 2500 

CB10 CB-10  -  CB-9 X = 9500 Y = 1000 
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WestRT 

 
CB5       CB7 
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CB8       CB10 
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9.2 Projecting Profiles to a Chain 
a) Click Component > Profile > Edit List from the GEOPAK Drainage Menu or by 

Drainage Profile List from the Drainage Toolbar and select the Profile WestLT. Click 
OK. 

 

 
b) Load the Profile Preferences file.  Inside the Edit Drainage Profile dialog, click File > 

Open.   

Navigate to C:Users\Public\Geopak Standards\ and select 
TDOTStormSewerProfiles-Plan.ppf.  Click Open.   
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c) Toggle ON Project to Chain in the Projection portion of the dialog. Click Identify Profile 
Cell and select the Profile Cell for the Roadway Profile and Data Point to accept. Click 
Apply. 

 
d) View the Projected Drainage Profile along the Roadway Profile.  

 

NOTE: Caution must be used when Projecting Drainage Profiles since the profile will be 
skewed to fit the station and elevation data of the roadway profile. 
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9.3 Ditch Profile 
a) Select from the Menu Bar: Component > Profile > Add or from the main toolbar: Add 

Drainage Profile 

b) Complete the Profile Configuration dialog box information as follows for the special 
ditch drainage network.  Click Apply when finished. 

Profile ID: DIT1  From Node: DIT-1 To Node: DIT-4 

c) Load the Profile Preferences file.  Inside the Edit Drainage Profile dialog, click File > 
Open. Navigate to C:Users\Public\Geopak Standards\ and select 
TDOTStormSewerProfiles-Design.ppf.  Click Open.   

d) Click the Registration tab and make the settings as below in the Registration Point, 
Scale and Reference Surface portions (make sure Project to Chain is toggled OFF). 
Click Apply. 

 

NOTE: For ditch profiles defined with Fixed Geometry, this dialog can be used to help 
identify and correct errors produced in the drainage calculations and ensure the 
drainage flows as it should. Our current ditch network set up is Cross Section Based on 
the existing terrain so that functionality is not applicable. 
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NOTES:  
For Cross Section Based links the invert generally follows the existing surface terrain. 

The yellow hydraulic grade line indicates locations where the existing ditch cross 
section geometry and water volume cause a rise or fall in the water surface elevation. 
Rises indicate points where greater capacity may be required. This information along 
with computation information provided with the links can be used to determine any 
possible special ditch needs. 

In Exercise 11, the system modification chapter, we will relocate these nodes and set 
the links as fixed geometry to define a special ditch set up to handle the drainage in this 
area. 
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9.4 Editing Links via Profiles 
The Edit Profiles dialog allows you to edit a Link’s design. This being the case the Link 
Configuration dialog must be closed in order to open the Edit Drainage Profile dialog. 

a) Open profile WestRT by selecting Component > Profile > Edit List or by selecting 
Drainage Profile List from the GEOPAK Drainage Main Toolbar. 

b) Click the Link Profile tab. Highlight the SS-2 Link ID. 

 
The SS-2 link’s control data is populated in the Details section at the bottom. 

 
From here you can set and hold the invert elevations, set the slope to hold or change 
the pipe size. 

Once any desired changes are made, click the Modify Segment icon on the right. An 
alert will appear. Click Yes, review and dismiss the warnings. 

c) Do not make any changes at this time. Click the red X to dismiss the dialog. 
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10. Drainage Navigator 
This exercise shows the user how to navigate a network and perform queries.   

10.1 Navigating/Query 
a) Select from the Drainage Menu Bar Utilities > Navigator or from the drainage main 

toolbar Drainage Navigator. 

 

b) Select the Drainage Nodes button on the Navigator: 

 

c) Toggle ON the Highlight and Window Center tools and click once on various 
nodes in the network. 
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As you can see the Drainage Navigator makes it easy to go to specific components in 
the network. A double click automatically opens the component's configuration dialog 
for easy editing of any Drainage component. 

d) Set the Active Component Type to Link and toggle the Query option: 
e) Use the Query tool to determine which Links have exceeded the Min Rise. Make the 

settings as shown and then click on Apply Query. 

 

Note the results of your query here: 

______________________________________ 
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f) Follow the same procedures to determine the following: 

Using Query type Values;  
Which pipes have a velocity less than 3 fps?  
______________________________________ 
(This will show you which links need to be modified to increase the velocity.) 

Using Query type Values;  
Which pipes have a velocity greater than 12 fps?  
_____________________________________ 
(This will show you which links need to be modified to decrease the velocity.) 

Using Query type Constraints;  
Which links have slopes less than Min Slope?   
_________________________________ 
(This will show you which links need to have their slopes increased.) 

Set the active component type to Inlet. 

Using Query type Constraints;  
Which inlets have exceeded their max ponded width?   
_________________________________ 
(This will show you which inlets need to be relocated to decrease the ponded width.) 
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10.2 Navigating/Global Editor 
From the query in Step 5 of Exercise 10.1 you should have found that 2 pipes were 
designed at a value greater than the minimum rise 1.5' (18"). These should have been 
SS-14 and SS-MH1. 

Since for the initial design we set our minimum depth of cover based on the minimum 
pipe size it will be necessary to check our catch basin depths to be sure they have not 
violated minimum depth requirements and to make sure that the larger pipe size is valid 
for the node which was used. To do this take the following steps: 

Checking Minimum Depth Requirements vs. Designed Node Depths & Pipe Sizes: 

a) Identify which drainage nodes are involved by going to Reports > Storm Drains/Links > 
Link Configuration in the GEOPAK Drainage menu bar. This report describes each link 
including From Node (Upstream), To Node (Downstream) and Size/Diameter (Rise). 
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b) Open the Navigator tool under Utilities and expand it to the Global Editor by choosing 

from the pull-down menu View > Global Editor. Once the Global Editor is open, click on 
the Node button. 

 
c) SS-MH1 is the first link shown in the Storm Drain Configuration Summary (Step 1). This 

link was designed by GEOPAK drainage to have a rise of 2.0 feet (24 inches). Find and 
select the Upstream Node (From Node) MH-1 for this Link in the Global Editor Dialog, 
then find and select Node – Minimum Depth in the Variable to Edit portion of the editor. 
Set the New Value to the correct minimum depth for a 2.0’ (24”) diameter pipe found in 
the TDOT GEOPAK Drainage Nodes document (Appendix A, pg. A-5). 

 
NOTE: If the type of structure for a given node is unknown or needs to be changed 
(would happen if pipe size is too large for a given catch basin), simply double click the 
Node ID in the Global Editor and the Node Configuration Dialog will be invoked. 

 

Min. Depth of Basin – Pipe Size – Drop Across Bottom of Structure = Minimum Depth 

MH#3 5’DIA:   4.08’    -    24”/12    -    0.21’    =    1.87’ 

 

d) Click Apply Edit With Confirm to apply the New Value and Click Yes in the Alert box. 

NOTE: Global Editor may be used to edit multiple Nodes/Links at once. 
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e) Repeat the previous steps to correct the minimum depth settings for the other storm 
drainage nodes for pipe link SS-14. 

 

Min Depth of Basin – Pipe Size – Drop Across Bottom of Structure = Minimum Depth 

CB#12 4x3,   24’DIA Pipe:   4.42   -   24”/12   -   0.17’   =   2.25’ 

                                    

f) Re-design the network WEST and review your profile. The Nodes should now meet 
minimum depth requirements. 

 

10.3 Re-Run the Network 
It is recommended that once a drainage network is set up all component constraints 
should be reviewed to insure that all criteria for design has been met. 

 

After re running the network WEST in Step 6 there are three errors:  

SS-8 Velocity less than minimum desired 

       SS-MH-1 Velocity greater than maximum desired 

       Capacity for Inlet CB-14 Exceeded Bypass Flow Unassigned 
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a) Navigate to Reports > Storm Drains/Links > Link Hydraulic Computations.  

For link SS-8, the slope is 8.512 and the actual velocity is 0.538.  To correct this error 
we can increase the slope of SS-8. The maximum slope  is 11 percent.  The upper end 
of SS-8 at CB-8 is at minimum depth, so we will have to lower the outlet end which is 
connected to CB-6.  For link SS-MH-1, the slope is the maximum 11% and the actual 
velocity is 16.560.  Looking at the profile, we definitely have some room to both lower 
the CB-6 outlet and to decrease the slope of SS-MH-1. 

 

b) Go to Component – Link- Edit – SS-8 – Conditions.  Fix the upper invert elevation at 
865.388 and the slope at 11.000 by checking the boxes next to the elevations. Click 
Apply after making changes. 
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c) Re- run Network WEST 

Upon checking the hydraulic computations, the new velocity is 7.592, which is in our 
acceptable range: 

 

Upon rerunning the network, you can see the profile automatically updated, the upper invert of 
SS-6 changing to 864.51 from 864.67 and the slope to 1.62% from 1.68%. : 

 

d) Now to correct, the high velocity in SS-MH-1, we need to reduce the slope.  In Link 
Configuration Conditions for SS-MH-1, the upper invert is 852.317 so let’s lower it to 
849.5 and fix the lower at its current value of 848.412 which is the outlet endwall. 
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Exercise 10 

 

Change to: 

 

 

e) Re-run Network WEST. 

   Check Hydraulic Computations, 10.943 is within our acceptable range 
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Also note that the profile at SS-MH-1 is automatically updated: 
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11. System Modification 
This exercise shows the user how to modify the storm drainage system design. Specifically we 
will combine links SS-14 & SS-MH1 by eliminating MH-1, change SS-13 to end at CB-12 
instead of at MH-1, reengineering the network connectivity. We will also change our ditch 
network set up to define a special ditch to handle the drainage along the base of the fill slope 
in that area. 

11.1 Storm Drainage Network Modification 
a) Delete Node MH-1 by using Drainage Navigator, selecting Component > Node > 

Delete from the Drainage Menu Bar, or by selecting Delete Drainage Node from the 
Drainage Toolbar. 

 
NOTE: Click Yes that you would like to delete the Node, OK to delete the Network 
WEST and NO to Do you want to delete all the components of the 
network as well? 

b) Follow the same basic procedures to delete Link SS-MH1. 
c) Edit Link SS-13, to start at the front face of CB-13 towards centerline and end at the front 

face of Node CB-12 across the road.  

 
d) Go to edit CB-12 and CB-13 to change the Library Item to CB#12 4’DIA. 

GEOPAK Drainage V8i (SELECT Series 2) System Modification    11-1 



REMINDER: Use the ID button to the right of the node list to identify the front wall 
connection points at nodes CB-13 and CB-12. 

 
NOTE: In an actual design, the skew angles would now need to be checked to ensure 
the pipe would fit in the catch basin wall. 

e) Edit Link SS-14, to go to Node EW-1. 

f) Since pipe at EW-1(link SS-14) is now a 24” pipe (from previous exercise) and the side 
slope at that location is 2:1, move the location of the outlet from an offset of 56’ to 
52’ to account for the length of the end wall and properly locate the outlet. 

g) Reset EW-1’s Max Depth to 2.0 (designed pipe size at outlet). 
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h) Add a New Network named WEST with the Outlet Node set to EW-1 (this is necessary 
since the network WEST was deleted in Step 1). Highlight the Network to ensure all 
components are connected, and then Design the Network. 

 
i) Update Profile WestRT to End at CB-12 and redraw other profiles as required based on 

these modifications. 

Optional: 

Depending on the drainage areas developed in the previous exercises you may still 
have errors in your network.  If your hydraulic gradeline exceeds the minimum 
freeboard, try increasing pipe sizes to lower the water surface.  If the velocity in Link 
SS-14 is over the maximum limit try hard coding SS-14’s invert elevation at Node CB-14 
to lower the slope of that Link. 
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11.2 Ditch Network Modification 
Initially, we set up a ditch network along a fill line using the Cross Section Based ditch 
type to analyze the drainage there. Now we will relocate our ditch nodes and set up our 
links as fixed geometry to design a special ditch along that slope to handle the drainage. 
Relocate Ditch Nodes and their Drainage Areas 

a) Delete previous drainage areas for ditch nodes. 
b) Go to Component > Node > Edit and select Node DIT-1. 

Under Location, change the station to 9+25 and the offset to 35.23.  
This is the beginning of the desired special ditch at the base of the fill slope. We will 
define the ditch link later as a “V” ditch with 2:1 side slopes although it will be at the 
existing ground elevation here at the beginning. 

 
Click Apply. 

c) Reference in the new DIT-1 file and use methods described previously to rebuild the 
DIT-1 drainage area for the new location, establish a time of concentration, apply land 
use areas and compute discharge.  

 
Click Apply to save the changes. 

d) Go to Component > Node > Edit and select Node DIT-2. 
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Under Location, change the station to 10+48 and the offset to 36.00.  
This is the point where we will achieve the 1 foot depth in our special ditch. By 
modifying the links at this location the ditch link will be a “V” ditch with 2:1 side slopes 
and is offset from the fill slope tie by 2 feet. 

 
Click Apply. 

e) Use methods described previously to rebuild the DIT-2 drainage area for the new 
location, establish a time of concentration, apply land use areas and compute discharge. 

Remember …ditch node drainage areas should include the area for the current node as 
well as any others previously defined that contribute to the ditch drainage network. 

 

 

Click Apply to save the changes. 
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f) Go to Component > Node > Edit and select Node DIT-3. 
Under Location, change the station to 11+85 and the offset to 43.00.  
This is the beginning of the final ditch slope and to mitigate the steeper slope and 
resulting increase in velocity we will change the ditch link section to a 2 foot wide 
trapezoidal shape, 1 foot deep with 2:1 side slopes and is offset from the fill slope tie by 
3 feet. 

 
Click Apply. 

g) Use methods described previously to rebuild the DIT-3 drainage area for the new 
location, establish a time of concentration, apply land use areas and compute discharge. 

 
 

Click Apply to save the changes. 
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h) Go to Component > Node > Edit and select Node DIT-4. 
Under Location, change the station to 13+28 and the offset to 72.00.  
This is the outlet for the special ditch and is shifted away from the fill slope tie to lead 
into the current existing drainage path. 

 
Click Apply. 

i) Use methods described previously to rebuild the DIT-4 drainage area for the new 
location, establish a time of concentration, apply land use areas and compute discharge. 

 
Click Apply to save the changes. 

Final layout of revised ditch nodes and drainage areas. 
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j) Since Node DIT-4 is an outlet type, it will not consider the drainage area developed for it. 
In order to ensure the final ditch link, DIT-3, will be adequate for the capacity at the end 
we will need to link the DIT-4 drainage area to it. 

Go to Component> Node> Edit and select node DIT-3. Under Discharge 
Options click on the option to Link Base Flow Area and set to include the 
DIT-4 drainage area. 

 

11.3 Ditch Link Modification 
Redefine Ditch Links with Fixed Geometry & Invert Elevations 

a) Go to Component > Link > Edit and select Link DIT-1. 
Under Definition, make the following changes: 
Ditch Type: Fixed Geometry 
Ditch Width: 0 (Toggle OFF Design Width) - for V-ditch 
Ditch Depth: 1 (Toggle OFF Design Depth) 
Side Slope Ratio Left (H:1): 2.00  
Side Slope Ratio Right (H:1): 2.00 
These settings define a “V” ditch at a 1’ depth with 2:1 side slopes. 
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NOTE: You can use the Design Width or Design Depth options individually but it is 
not recommended to use both at the same time. The software will always use the 
Minimum Rise value under Constraints for the depth and only adjusts the width if 
needed from that point. 

b) Under Conditions, make the following changes: 
From Node Invert: 867.599 (existing ground elevation) 
To Node Invert: 865.058 (1 foot below existing ground elevation) 

These settings provide the transition 
from existing ground to the 1’ depth.  
NOTE: The large numbers you may 
see specified for Soffit elevations can 
be ignored. These values are a result 
of the previous application of the 
Cross Section Based ditch type where 
these values are not applicable. When 
the ditch network is redesigned, the 
Soffit elevations will be recalculated. 
 

c) Under Constraints, make the following change: 
Minimum Rise: 1.000 (to allow for defined 1 foot depth) 

 

d) Click Apply to save the changes to link DIT-1. 
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e) In the Link Configuration Definition dialog go to Link DIT-2. 
 Under Definition, make the following changes: 

Ditch Type: Fixed Geometry 
Ditch Width: 0 (Toggle OFF Design Width) – for V-ditch 
Ditch Depth: 1 (Toggle OFF Design Depth) 
Side Slope Ratio Left (H:1): 2.00  
Side Slope Ratio Right (H:1): 2.00 
These settings define a “V” ditch at a 1’ depth with 2:1 side slopes. 

  
f) Under Conditions, make the following changes: 

From Node Invert: 865.058 (1 foot below existing ground elevation) 
To Node Invert: 860.678 (1 foot below existing ground elevation) 

  
These settings maintain the 1’ depth below the existing ground. 
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g) Under Constraints, make the following change: 
Minimum Rise: 1.000 (to allow for defined 1 foot depth) 

  

Click Apply to save the changes to link DIT-2. 
h) In the Link Configuration Definition dialog go to Link DIT-3. 

Under Definition, make the following changes: 
Ditch Type: Fixed Geometry 
Ditch Width: 2 (Toggle OFF Design Width)  
Ditch Depth: 1 (Toggle OFF Design Depth) 
Side Slope Ratio Left (H:1): 2.00  
Side Slope Ratio Right (H:1): 2.00 

 

  
These settings define a 2’ wide trapezoidal (flat bottom) ditch at a 1’ depth with 2:1 
side slopes. 

Note:  See Appendix E for Roughness Values for Open Channel Hydraulics. 
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i) Under Conditions, make the following changes: 
From Node Invert: 860.678 (1 foot below existing ground elevation) 
To Node Invert: 850.037 (existing ground elevation) 

  
These settings provide the transition from the 1’ depth back to the existing ground 
elevation at the end of the ditch. 

j) Under Constraints, make the following change: 
Minimum Rise: 1.000 (to allow for defined 1 foot depth) 

  
k) Click Apply to save the changes to link DIT-3. 

 
NOTE: You can select the entire ditch of one profile, copy beside itself, select all and 
Edit > Group so that you will still have the ditch profile from before modifications and you 
can compare. 
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11.4 Redesign Ditch Network & Review 
a) Go to Network > Active Network and select WEST DIT. 

b) Go to Network > Design to run the network. 
c) Review any errors that are generated by the redesign of the network and close the text 

editor. (See Appendix C for common errors and fixes) 

 

d) Review computation results. 

Go to Component > Link > Edit and review the link computations for links DIT-1, 
DIT-2 & DIT-3. 
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Go to Reports> Storm Drains\Links> Link Hydraulic Computations. 

 

e) Zoom in on the ditch profile graphics. 
The profile has been automatically updated and reflects our new proposed ditch 
definitions. 
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12. Reports 
This exercise shows the user the report options by creating standard and customized reports. 

12.1 Customized Reports 
a) Select Reports > Generate from the Drainage Menu Bar or Drainage Generate Report 

from the Drainage Toolbar: 

 

 

 

b) Use the browse button to select report format file TDOTnodesFULL.drf (from 
C:\Users\Public\Geopak Standards\). Click in the Output File Name area and type in 
nodes.csv as the file name. Click Generate to create the report file. 

 

c) Use Excel to open and review nodes.csv report file. 

d) Access report format TDOTlinksFULL.drf and generate links.csv report file. 

e) Use Excel to open and review links.csv report file. 
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12.2 Excel Tab Builder 
a) Open Excel and click File > New 

b) Click My templates > TDOT English Tab Quantities > Storm Drainage Structure Tab 
Builder 

 If the “My templates” button does not provide you with the Storm Drainage Structure Tab 
Builder excel file, then navigate to C:\Users\Public\Office Standards\TDOT English 
Tab Quantities and open the file there.  Do a “Save As” and save it into your Project 
folder before making any changes. 

c) Click Build Catch Basins and Manholes Block. 

d) Navigate to the project folder, select the file nodes.csv created in Exercise 12.1 and 
click open. The tab block is created. 

 
e) Repeat Step 1 through Step 4 using the links.csv file and the Storm Drainage Pipe 

Tab Builder 
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12.3 Standard Reports 
 

Geopak Drainage also provides several standard reports which are useful during storm 
drainage network design. The current Active Network will determine which drainage 
features are listed. 

a) Select Reports > Drainage Areas from the Drainage Menu Bar. 

 
b) Select Reports > Inlets> On Grade Inlets from the Drainage Menu Bar. 

 
Sag Inlets 
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c) Select Reports > Storm Drains/Links> Link Configuration from the Drainage Menu 
Bar. 

 
Link Hydraulic Calculations 
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13. Storm Drainage Labeling 
This exercise shows the user how to use standard labels by labeling the plan and profile views. 
The Labeler automates the composition and placement of many types of labels into the dgn 
file. This interactive tool permits the creation of very simple to very complex labels.  

13.1 Plan View Labeling 
a) Open the Drainage Labeler by selecting Utilities > Labeler from the pull down menu or 

Drainage Labeler from the Drainage Toolbar. 
 

 

 

b) Click on the Style tab, double click Plan Code under the Storm Drainage category and 
double click it to make it the active style. 

 

c) Zoom in to CB-1 in plan view. 
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d) Click on the Text tab, then click the Nodes icon and toggle ON Window Center. 
e) Click on CB-1 from the node list. Label data is automatically set for that node and view 

centers at node location. 

 
f) Select from the pulldown menu: Scale > Change Scale and change to 50. 
g) Click the Place Label button on the right of dialog to initiate placement of the label. 
h) Move the cursor to position the label and data point to place the label in the vicinity of 

CB-1. If the label text is not horizontal to the view or alignment, you may need to go to 
the Rotate tab to set the angle prior to placement. 

i) Move the cursor around and data point once again to locate the leader line point of 
beginning (i.e. where you want the leader to connect to the label). 

 
j) Click the Style tab and set the active style to GrateOut-0IN with a double click. 
k) Click the Text tab and select CB-1. Click Place Label and data point next to the Code 

Label to position the text. 
NOTE: For catch basins with one or more inlets, elevation labels will require an extra 
step to insert the inlet elevation(s).  
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l) Place labels for CB-3 which includes 2 inlet pipes. 
1. Click the Style tab and set the active style to GrateOut-2IN with a double click. 
2. Click the Text tab and select CB-3. Click Place Label and data point next to the 

Code Label to position the text. 
3. Click the Style tab and set the active style to Inlet Elev with a double click. 
4. Click the Text tab and select SS-1. Click Place Label and data point below the GT. 

EL. Text placed in step b. 
5. Select SS-7. Click Place Label and data point below the IN. EL. Text placed in 

step d. 

 
m) Place the remaining plan view Node labels. 

13.2 Profile View Labeling 
Normally the plan view displays most of the data for a catch basin, however, in some 
circumstance labels on the profile may be required. 

a) Click on the Styles tab and double click on the style Profile Code to activate it. 

b) Click on the Rotate tab and click on Current Angle (If needed set to 0) 
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c) Click on the Text tab and toggle OFF the Window Center Box. This option works with 
plan view only. 

d) Zoom in on the alignment profile view in the vicinity of CB-1. 

e) Click on CB-1 in the node list and then click Place Label. 

f) Locate in profile view and place the label. 

g) Repeat until all codes are placed for all nodes in the profile view. 

Leader Line Optional Steps: 

Step 8. Use MicroStation's Match Element Attributes and click on any code 
placement. 

Step 9. Use MicroStation’s Place Line to place leader lines from code placement to 
node. 

 

NOTE:  
Pipes are automatically annotated correctly for the plans when the preference file 
TDOTStormSewerProfiles-Plan.ppf is used for profile display control. When using 
label style Profile pipe to label proposed pipes on the profile … 
1) Select the link under the Text tab  
2) Go to the Rotate tab and set to Element Angle 
3) Click Element button in the Set Angle By portion of the dialog and identify the 

bottom of pipe on the profile to set label angle. 
4) Data point to place label. 
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14. Design & Computation Manager with  
Drainage Links 
This exercise shows the user how to use the D&C Manager to control symbology, compute 
quantities, which can be used in preliminary estimates, and set pay items for drainage links by 
setting the symbology of all pipes and generating pipe quantities for this project. 

14.1 Set Link Symbology 
a) Select Components > Links > Update With Pay Items from the main menu bar or 

Update Links with Pay Items from the Drainage Toolbox. 

 

b) Utilize the MicroStation command Fit View to view the entire Drainage Network. 

 
c) Note that the Link symbology has changed to reflect that of the D&C Manager. All links 

use appropriate custom line styles and are labeled with ST's and pipe size. 
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14.2 Label Short Pipe Links 
Often we have cases where the pipes are too short for their symbology to show as is 
the case with the pipes from various drop inlets just off the roadway in this project. We 
have a tool available to handle these with a separate label which is available through 
D&C Manager. 

a) Open the Design and Computation Manager and select item Drafting Standards> 
Prop. Drainage> Label ST Pipe. 

 
b) The Place Prop. Storm Drainage Pipe Label dialog opens and you are prompted to 

identify the pipe. Data point on link SS-7, the pipe between CB-7 and CB-3, and the 
appropriate text is filled in on the dialog.  
By default the label will come up as text only at the angle of the pipe. If there is room, 
you can place the label as such along the pipe. 
For pipes too short for that, click on the option to Place Label as Flag and click the 
Place Label button. 
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c) Data point on or near the pipe for the beginning of the leader and once again to position 
the label which is shown dynamically. 

 

d) Use the Identify Pipe button to read and label the other short pipe links on the project.  

You may wish to use one of the terminator options for pipes in tight places with other 
text and line work. 
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14.3 Compute Link Quantities 
a) Open the Design and Computation Manager and set the Mode to Compute by clicking 

the 'calculator' icon button. 
b) Under Pay Items, highlight the Prop. Drainage category, then click the Add to 

Collection button on the Design & Computation Manager toolbar. 

 
c) Within the Plan Quantity Computation box ensure Extents: is set to Active Design File. 

Click the Compute Quantities button for initiation of the report.  Your results may vary. 

 
NOTE: To limit the extent of calculation set Extents: to Station Range, and set the limits 
desired in the Baseline Reference portion of the dialog. 

d) Select your Export Format. Select CSV By Item for use with standard estimate files. 
Type in drainage.csv for the filename  and click on Export.   
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In the Estimated Roadway Quantities Excel file use the Import CSV File for Items 
command button to import the data compiled with D&C Manager. 

NOTE: This function reads only the item number and quantity from the csv file. Item 
description and unit are pulled from the official item number listing. 

 

14.4 Alternate Pay Items for Links 
a) Open Edit Link and select Link SS-14. 

b) In Definition, under the Configuration portion, toggle ON Override Library Payitem. 
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c) Click on the calculator button to select an 
alternate pay item. Go to Pay Items > 
Storm Sewer Pipes > 607-07.03 36” storm 
sewer pipe Class 4.  
Double click on the 36” Class 4 Concrete 
pipe item to switch it from the defaulted 
Class 3 item number. 

NOTE:  All circular concrete pipes are set 
up with Class 3 concrete pipe item 
numbers. When setting up a system of 
median drains for depressed grass medians 
then all pipes will need to be set to use 
alternate pipe item numbers as listed under 
D & C manager category Pay Items > 
Drainage Items > Crossdrains & Median 
Drains. 

 
d) Click Apply in the Link Configuration Definition dialog to accept the change. 

Follow Exercise 14.1 to update the link graphics.  
Follow Exercise 14.3 to re-compute the quantities and see the difference. 

 
 

NOTE:  See Appendix G for Pipe Selection Criteria based on system and fill height. 
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Appendix B 

GEOPAK Drainage V8i (SELECT Series 2) Completing Drainage Areas    B-1 

Completing Drainage Areas 
This exercise shows options for the user to calculate drainage areas not included in the survey 
TIN file.  

Step 1. Create a TIN Surface for areas outside the Survey TIN. Follow the processes 
outlined in the Creating Geopak TIN Surfaces from USGS DEM Data document 
available from the Roadway Design Division – CADD Standards and Downloads 
website. 

Step 2. Merge the project Final TIN with the TIN surface created in Step 1.  
a. Open DTM Tools by clicking Applications> GEOPAK> Road> DTM Tools.  
b. Within the DTM Tools dialog select Build Merge TINs.  

 
c. Set Old TIN: to the TIN File created in Step 1. Set Mrg TIN: to the Final 

Project TIN file. Create a unique name for the New TIN: file. 

 
d. Click Process. 

Step 3. Visualize contours for the New Merged TIN utilizing steps from the TDOT 
GEOPAK Road Course Guide, Exercise 22b. 

Step 4. Use this process with DTM tools presented in this document in conjunction with 
MrSID images or other aerial photography to determine approximate flow paths 
and drainage areas.  
NOTE: MrSID images can be attached by following the process in the Using 
MrSID Image Files in MicroStation document. 

http://www.tdot.state.tn.us/Chief_Engineer/assistant_engineer_design/design/v8/TINSurfaceFromDEM.pdf
http://www.tdot.state.tn.us/Chief_Engineer/assistant_engineer_design/design/v8/TDOTGEOPAKRoadCourseGuide.pdf
http://www.tdot.state.tn.us/Chief_Engineer/assistant_engineer_design/design/v8/TDOTGEOPAKRoadCourseGuide.pdf
http://intranet.tdot.tn.gov/asstchiefengrdesign/Design/v8design/Using%20MrSID%20Image%20Files%20in%20MicroStation.pdf
http://intranet.tdot.tn.gov/asstchiefengrdesign/Design/v8design/Using%20MrSID%20Image%20Files%20in%20MicroStation.pdf


B-2   Completing Drainage Areas GEOPAK Drainage V8i (SELECT Series 2) 

Example image with expanded surface information: 

 



Appendix C 

GEOPAK Drainage V8i (SELECT Series 2) Common Network Errors and Fixes    C-1 

Common Network Errors and Fixes 
This information shows common network errors experienced and possible solutions to correct 
them. 

Error: 

Link SS- # velocity less than minimum desired. 

Solutions: 

Increase the slope of the pipe/ditch. 

Decrease the size of the pipe/ditch (if possible) (Smaller flow area means 
higher velocity). 

Change the type of pipe/ditch (if possible) (Smoother pipes typically have 
higher velocities). 

Error: 

Link SS - # velocity greater than maximum desired. 

Solutions: 

Decrease the slope of the pipe/ditch. 

Increase the size of the pipe/ditch (if possible) (Larger flow areas means 
lower velocity). 

Change the type of pipe/ditch (if possible) (Rougher pipes typically have 
lower velocities). 

Error: 

Capacity for Inlet CB - # Exceeded Bypass Flow Unassigned. 

Solutions: 

Assign a downstream node to accept the bypass. 

Use double or other multi-grate catch basin or drop inlet. 

Add additional upstream catch basin(s) to ensure all runoff is captured 
within the system. 

If none of the above are feasible/practical, ensure the bypass flow has a 
place to flow into another storm drain system or roadside ditch and the 
error can be ignored. 

Error: 

Computed Ponded Width for Inlet CB - # Exceeds Maximum. 

Solutions: 

Move closer to upstream catch basin. 

Add additional catch basin upstream. 



C-2   Common Network Errors and Fixes GEOPAK Drainage V8i (SELECT Series 2) 

Error: 

HGL Blowout upstream of Link SS - # minimum freeboard not achieved 

Solutions:  

For Storm Sewers: Increase pipe size. 

Increase pipe slope. 

For Ditches: The top of node should be below the Hydraulic 
Grade Line (HGL). Confirm the HGL is below 
the soffit and ignore error. 

Error: 

Min/Max Depth Exceeded at Upstream/Downstream of Link SS- #. 

Solutions: 

For Storm Sewers: Check held elevations and slopes in the Link 
Configurations Conditions dialog. 

For Ditches: Confirm node/link elevations are correct and 
ignore error. 

Error: 

Profile Warning for Link SS - #: 
–>Minimum Slope used for Positive Drainage 
–>Check Held Elevations and Slopes 

Solutions: 

Check held elevations and slopes in the Link Configurations Conditions 
dialog. Make changes as necessary. 

Error: 

Soffit elevation adjusted for ditches: 

Solutions: 

No correction required, normal adjustment required when ditch inverts are 
held at specific elevations. 

Error: 

Catch Basin Minimum Depth exceeded on most catch basins,  
depth gets progressively deeper from beginning of network to end. 

Solutions: 

Check Link preferences, turn off rounding of link slopes if on. 



Manning's N and Intercept K Values            Appendix D 

GEOPAK Drainage V8i (SELECT Series 2) Manning's n and Intercept K values  D-1 

 



D-2  Manning's n and Intercept K values   GEOPAK Drainage V8i (SELECT Series 2) 

 



Manning's N for Uniform Flow                         Appendix E 

GEOPAK Drainage V8i (SELECT Series 2) Manning's n for Uniform Flow  E-1 

 

 



Total Energy in Open Channel Flow               Appendix F 

GEOPAK Drainage V8i (SELECT Series 2) Total Energy in Open Channel Flow  F-1 

 

 



Pipe Selection Criteria                                   Appendix G 

GEOPAK Drainage V8i (SELECT Series 2) Pipe Selection Criteria G-1 

 

 



Storm Sewer Sketch                                       Appendix H 

GEOPAK Drainage V8i (SELECT Series 2) Storm Sewer Sketch  H-1 

 

 



IDF ZONE Location Map                                       Appendix I 

GEOPAK Drainage V8i (SELECT Series 2) IDF Zone Location Map  I-1 

 

 



Hydrologic Design Criteria  Appendix J 

 

GEOPAK Drainage V8i(SELECT Series 2)  Hydrologic Design Criteria J-1 



Catch Basin Data Table  Appendix K 
 

 

Exercise 5 Catch Basin Values 

CB Drainage Area Tc Discharge Spread Width 

1 1.03 31.361 1.58 5.411 

2 1.741 33.65 2.429 6.99 

3 0.182 9.15 0.785 3.0179 

4 0.581 3.724 1.877 6.029 

5 1.275 34.154 1.282 3.073 

6 0.257 1.595 1.343 5.5181 

7 7.143 36.141 7 5.786 

8 0.895 28.956 0.941 1.444 

9 0.689 35.051 0.886 4.0723 

10 2.733 37.2 2.63 1.725 

11 0.191 34.8 0.337 1.759 

12 0.199 1.421 1.106 4.836 

13 0.156 1.238 0.877 7.273 

14 0.286 2.372 1.767 4.81 
 

GEOPAK Drainage V8i (SELECT Series 2)                                                   CB Data Table K-1 
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